summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-04 11:08:36 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-04 11:08:36 +0000
commit4a57a1c29f55298f2d3dbf8ca399f5410ba424ef (patch)
tree813a7b8766b873b375fa859c59ea2d63f904b7e5 /dev-ruby
parentversion bump. Bug #390395. Thanks to Patrick <mail@patrick-nagel.net> (diff)
downloadgentoo-2-4a57a1c29f55298f2d3dbf8ca399f5410ba424ef.tar.gz
gentoo-2-4a57a1c29f55298f2d3dbf8ca399f5410ba424ef.tar.bz2
gentoo-2-4a57a1c29f55298f2d3dbf8ca399f5410ba424ef.zip
Merge the ebuild from my overlay. Fix USE=doc, run tests since they work for me.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/posix-spawn/ChangeLog6
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild21
2 files changed, 18 insertions, 9 deletions
diff --git a/dev-ruby/posix-spawn/ChangeLog b/dev-ruby/posix-spawn/ChangeLog
index 98b279dddc3a..1ae045cb957f 100644
--- a/dev-ruby/posix-spawn/ChangeLog
+++ b/dev-ruby/posix-spawn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/posix-spawn
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.1 2011/04/24 20:57:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.2 2011/12/04 11:08:36 graaff Exp $
+
+ 04 Dec 2011; Hans de Graaff <graaff@gentoo.org> posix-spawn-0.3.6.ebuild:
+ Merge the ebuild from my overlay. Fix USE=doc, run tests since they work for
+ me.
*posix-spawn-0.3.6 (24 Apr 2011)
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild
index a522208c74cf..7c257512eef1 100644
--- a/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild,v 1.1 2011/04/24 20:57:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild,v 1.2 2011/12/04 11:08:36 graaff Exp $
EAPI=2
@@ -8,22 +8,27 @@ EAPI=2
USE_RUBY="ruby18 ruby19 ree18"
KEYWORDS="~amd64"
+RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
inherit ruby-fakegem
-DESCRIPTION="Ruby library to access ELF files information"
-HOMEPAGE="http://www.flameeyes.eu/projects/ruby-elf"
+DESCRIPTION="The posix-spawn library aims to implement a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
LICENSE="MIT LGPL-2.1"
SLOT="0"
IUSE="test"
-ruby_add_bdepend ">=dev-ruby/rake-compiler-0.7.6"
-
-# https://github.com/rtomayko/posix-spawn/issues/11
-RESTRICT=test
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
each_ruby_compile() {
- ${RUBY} -S rake compile || die
+ emake -Cext
+ cp ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test || die
}