summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-24 09:09:20 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-24 09:09:20 +0000
commit36609f840208848ec9e1a4ddba76f086476007cb (patch)
treede3f9bef5e6734faf76ec9e2831d3382cb173937 /dev-ruby
parentFix underlink. Bug #367647 (diff)
downloadgentoo-2-36609f840208848ec9e1a4ddba76f086476007cb.tar.gz
gentoo-2-36609f840208848ec9e1a4ddba76f086476007cb.tar.bz2
gentoo-2-36609f840208848ec9e1a4ddba76f086476007cb.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/multi_json/ChangeLog9
-rw-r--r--dev-ruby/multi_json/multi_json-1.0.2.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 8d3318e294d7..3d808bde923b 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_json
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.4 2010/10/02 12:22:11 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.5 2011/05/24 09:09:20 graaff Exp $
+
+*multi_json-1.0.2 (24 May 2011)
+
+ 24 May 2011; Hans de Graaff <graaff@gentoo.org> +multi_json-1.0.2.ebuild:
+ Version bump.
02 Oct 2010; Hans de Graaff <graaff@gentoo.org> multi_json-0.0.4.ebuild:
Remove bundler code because it requires all optional dependencies to be
diff --git a/dev-ruby/multi_json/multi_json-1.0.2.ebuild b/dev-ruby/multi_json/multi_json-1.0.2.ebuild
new file mode 100644
index 000000000000..c6dc4acecea8
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.0.2.ebuild,v 1.1 2011/05/24 09:09:20 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="http://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
+
+# I've switched one of the tests from requiring yajl to requiring
+# json-pure since it's the only implementation that is available for
+# all the Ruby interpreters we support.
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/json )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+ rm Gemfile || die "Unable to remove bundler Gemfile."
+
+ # Provide version otherwise provided by bundler.
+ sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
+}