summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-07 06:49:09 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-07 06:49:09 +0000
commit8bc4f97b2e4916cb27c765c55e5cf50ad2417d01 (patch)
treef4d39b85e7b2562b5c145bcd0bbaa4ea6faa15e0 /dev-ruby/tzinfo
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-8bc4f97b2e4916cb27c765c55e5cf50ad2417d01.tar.gz
gentoo-2-8bc4f97b2e4916cb27c765c55e5cf50ad2417d01.tar.bz2
gentoo-2-8bc4f97b2e4916cb27c765c55e5cf50ad2417d01.zip
Version bump: Updated to tzdata version 2010h.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog7
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.19.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index e8811aded42b..030844fae7fe 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.52 2010/04/03 12:12:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.53 2010/04/07 06:49:09 graaff Exp $
+
+*tzinfo-0.3.19 (07 Apr 2010)
+
+ 07 Apr 2010; Hans de Graaff <graaff@gentoo.org> +tzinfo-0.3.19.ebuild:
+ Version bump: Updated to tzdata version 2010h.
03 Apr 2010; Hans de Graaff <graaff@gentoo.org> tzinfo-0.3.16.ebuild:
Drop ruby19 and jruby to facilitate stabling this specific version.
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.19.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.19.ebuild
new file mode 100644
index 000000000000..3994613357a1
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.19.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.19.ebuild,v 1.1 2010/04/07 06:49:09 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+all_ruby_prepare() {
+ # The package has all the files executable, probably coming from
+ # Windows.
+ find "${S}" -type f -perm +111 -exec chmod -x {} +
+
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i -e '138,146s:^:#:' "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}