summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-02-14 02:55:47 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-02-14 02:55:47 +0000
commit111712b8dc9208036d6d513f21df2ca0e127d713 (patch)
tree6e12c023e97ec16d24f32fa75b85f2cdd7f7b2a1 /dev-ruby/typhoeus
parentVersion bump. Remove old. (diff)
downloadgentoo-2-111712b8dc9208036d6d513f21df2ca0e127d713.tar.gz
gentoo-2-111712b8dc9208036d6d513f21df2ca0e127d713.tar.bz2
gentoo-2-111712b8dc9208036d6d513f21df2ca0e127d713.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/typhoeus')
-rw-r--r--dev-ruby/typhoeus/ChangeLog10
-rw-r--r--dev-ruby/typhoeus/typhoeus-0.7.1.ebuild30
2 files changed, 37 insertions, 3 deletions
diff --git a/dev-ruby/typhoeus/ChangeLog b/dev-ruby/typhoeus/ChangeLog
index 032cf706fb5a..715244d32999 100644
--- a/dev-ruby/typhoeus/ChangeLog
+++ b/dev-ruby/typhoeus/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-ruby/typhoeus
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/typhoeus/ChangeLog,v 1.1 2014/09/01 05:52:35 graaff Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/typhoeus/ChangeLog,v 1.2 2015/02/14 02:55:47 mrueg Exp $
+
+*typhoeus-0.7.1 (14 Feb 2015)
+
+ 14 Feb 2015; Manuel Rüger <mrueg@gentoo.org> +typhoeus-0.7.1.ebuild:
+ Version bump.
*typhoeus-0.6.9 (01 Sep 2014)
01 Sep 2014; Hans de Graaff <graaff@gentoo.org> +typhoeus-0.6.9.ebuild,
+metadata.xml:
Initial import. Dependency for forthcoming dev-ruby/vcr.
-
diff --git a/dev-ruby/typhoeus/typhoeus-0.7.1.ebuild b/dev-ruby/typhoeus/typhoeus-0.7.1.ebuild
new file mode 100644
index 000000000000..af6e393a51a6
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/typhoeus/typhoeus-0.7.1.ebuild,v 1.1 2015/02/14 02:55:47 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
+HOMEPAGE="http://rubygems.org/gems/typhoeus/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/ethon-0.7.1"
+
+ruby_add_bdepend "test? ( dev-ruby/json >=dev-ruby/faraday-0.9 >=dev-ruby/sinatra-1.3 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}