summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-03-29 10:21:50 +0000
committerHans de Graaff <graaff@gentoo.org>2014-03-29 10:21:50 +0000
commitb400077c1ffcb5e68d89ae3ec4c49aa5dd99a5c9 (patch)
tree3a379ad58f6afab2920dac706a13e293f0584729 /dev-ruby/thread_safe
parentold (diff)
downloadgentoo-2-b400077c1ffcb5e68d89ae3ec4c49aa5dd99a5c9.tar.gz
gentoo-2-b400077c1ffcb5e68d89ae3ec4c49aa5dd99a5c9.tar.bz2
gentoo-2-b400077c1ffcb5e68d89ae3ec4c49aa5dd99a5c9.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/thread_safe')
-rw-r--r--dev-ruby/thread_safe/ChangeLog7
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.3.1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/thread_safe/ChangeLog b/dev-ruby/thread_safe/ChangeLog
index ba4c1674c69b..e6fdd49010b0 100644
--- a/dev-ruby/thread_safe/ChangeLog
+++ b/dev-ruby/thread_safe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/thread_safe
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/ChangeLog,v 1.11 2014/02/28 06:54:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/ChangeLog,v 1.12 2014/03/29 10:21:50 graaff Exp $
+
+*thread_safe-0.3.1 (29 Mar 2014)
+
+ 29 Mar 2014; Hans de Graaff <graaff@gentoo.org> +thread_safe-0.3.1.ebuild:
+ Version bump.
*thread_safe-0.2.0 (28 Feb 2014)
diff --git a/dev-ruby/thread_safe/thread_safe-0.3.1.ebuild b/dev-ruby/thread_safe/thread_safe-0.3.1.ebuild
new file mode 100644
index 000000000000..dc2c52510116
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/thread_safe-0.3.1.ebuild,v 1.1 2014/03/29 10:21:50 graaff Exp $
+
+EAPI=5
+# jruby → there is code for this in ext but that requires compiling java.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/headius/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+# Higher atomic dependency since earlier versions crash on ruby20 while
+# running thread_safe tests.
+ruby_add_rdepend ">=dev-ruby/atomic-1.1.16"
+
+each_ruby_prepare(){
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}