summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-01-24 00:07:35 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-01-24 00:07:35 +0000
commit3511c16ec0d249fe462b910a195b5176fd37ba2a (patch)
treed7b8989b375b519fa810df341724a709cd7857e2 /dev-ruby/tclink/tclink-3.4.4.ebuild
parentInitial import, from bug #144413 (diff)
downloadgentoo-2-3511c16ec0d249fe462b910a195b5176fd37ba2a.tar.gz
gentoo-2-3511c16ec0d249fe462b910a195b5176fd37ba2a.tar.bz2
gentoo-2-3511c16ec0d249fe462b910a195b5176fd37ba2a.zip
Need to set RDEPEND too
(Portage version: 2.1.4)
Diffstat (limited to 'dev-ruby/tclink/tclink-3.4.4.ebuild')
-rw-r--r--dev-ruby/tclink/tclink-3.4.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/tclink/tclink-3.4.4.ebuild b/dev-ruby/tclink/tclink-3.4.4.ebuild
new file mode 100644
index 000000000000..5d450a37fe3f
--- /dev/null
+++ b/dev-ruby/tclink/tclink-3.4.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tclink/tclink-3.4.4.ebuild,v 1.1 2008/01/24 00:07:34 caleb Exp $
+
+inherit ruby
+
+MY_P=${P}-ruby
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="http://www.trustcommerce.com/tclink.html"
+SRC_URI="http://www.trustcommerce.com/downloads/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="=dev-lang/ruby-1.8*
+ >=dev-libs/openssl-0.9.8"
+DEPEND=${RDEPEND}
+
+src_compile() {
+ ./build.sh
+ ruby tctest.rb
+}
+
+