summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-05 10:29:27 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-05 10:29:27 +0000
commit755362c2456affee27e4d6ab90a4209d6c89bae3 (patch)
tree56f51a0abb36a5e1d640624a178b358dda5f3764 /dev-ruby/sexp_processor
parentAdd ruby20 target. (diff)
downloadgentoo-2-755362c2456affee27e4d6ab90a4209d6c89bae3.tar.gz
gentoo-2-755362c2456affee27e4d6ab90a4209d6c89bae3.tar.bz2
gentoo-2-755362c2456affee27e4d6ab90a4209d6c89bae3.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/sexp_processor')
-rw-r--r--dev-ruby/sexp_processor/ChangeLog7
-rw-r--r--dev-ruby/sexp_processor/sexp_processor-4.3.0-r1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/sexp_processor/ChangeLog b/dev-ruby/sexp_processor/ChangeLog
index 9de13e06ff66..af0dfb95e2cb 100644
--- a/dev-ruby/sexp_processor/ChangeLog
+++ b/dev-ruby/sexp_processor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/sexp_processor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sexp_processor/ChangeLog,v 1.21 2013/09/15 09:57:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sexp_processor/ChangeLog,v 1.22 2013/10/05 10:29:27 mrueg Exp $
+
+*sexp_processor-4.3.0-r1 (05 Oct 2013)
+
+ 05 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +sexp_processor-4.3.0-r1.ebuild:
+ Add ruby20 target.
15 Sep 2013; Agostino Sarubbo <ago@gentoo.org> sexp_processor-4.2.1.ebuild:
Stable for amd64, wrt bug #483708
diff --git a/dev-ruby/sexp_processor/sexp_processor-4.3.0-r1.ebuild b/dev-ruby/sexp_processor/sexp_processor-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..5293779766af
--- /dev/null
+++ b/dev-ruby/sexp_processor/sexp_processor-4.3.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sexp_processor/sexp_processor-4.3.0-r1.ebuild,v 1.1 2013/10/05 10:29:27 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for s-expressions created as part of the ParseTree project."
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/ParseTree/"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest
+ )"