summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-01 16:41:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-01 16:41:37 +0000
commit5d25fa03987b335167c948b5170803f0eab3c9e5 (patch)
tree869e70005f2911553d8c4dbd087ed80a4c754d0f /dev-ruby/ruby-progressbar
parentRespect LDFLAGS. amd64 stable wrt bug #329947 (diff)
downloadgentoo-2-5d25fa03987b335167c948b5170803f0eab3c9e5.tar.gz
gentoo-2-5d25fa03987b335167c948b5170803f0eab3c9e5.tar.bz2
gentoo-2-5d25fa03987b335167c948b5170803f0eab3c9e5.zip
Add a new revision for 1.9/JRuby to mark -r0 stable.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/ChangeLog8
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9-r1.ebuild31
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild4
3 files changed, 40 insertions, 3 deletions
diff --git a/dev-ruby/ruby-progressbar/ChangeLog b/dev-ruby/ruby-progressbar/ChangeLog
index b2107a61a626..89c955ff87a3 100644
--- a/dev-ruby/ruby-progressbar/ChangeLog
+++ b/dev-ruby/ruby-progressbar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-progressbar
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.26 2010/08/01 16:35:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.27 2010/08/01 16:41:37 flameeyes Exp $
+
+*ruby-progressbar-0.0.9-r1 (01 Aug 2010)
+
+ 01 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ ruby-progressbar-0.0.9.ebuild, +ruby-progressbar-0.0.9-r1.ebuild:
+ Add a new revision for 1.9/JRuby to mark -r0 stable.
01 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
ruby-progressbar-0.9.ebuild:
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9-r1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9-r1.ebuild
new file mode 100644
index 000000000000..5de9b435dcf6
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9-r1.ebuild,v 1.1 2010/08/01 16:41:37 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="http://github.com/nex3/ruby-progressbar"
+
+LICENSE="|| ( Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="test"
+
+each_ruby_test() {
+ # tests need to be run from within the lib dir but they require
+ # lib/progressbar.rb, so we do this silly stuff, but it works at
+ # least
+ cd lib
+ ${RUBY} -I.. ../test.rb || die "test failed"
+}
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild
index 877b22e253be..0caaace88942 100644
--- a/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild,v 1.1 2010/01/18 02:14:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-0.0.9.ebuild,v 1.2 2010/08/01 16:41:37 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_TASK_DOC=""