summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-17 01:03:26 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-17 01:03:26 +0000
commit75a6ec707d4d3143f6dbba4d90f63ed9dda7877f (patch)
treef1bb6aba5083907ab7693cf38e72628d76ee54fb /dev-ruby/ruby-gobject-introspection
parentVersion bump. Add ruby21. (diff)
downloadgentoo-2-75a6ec707d4d3143f6dbba4d90f63ed9dda7877f.tar.gz
gentoo-2-75a6ec707d4d3143f6dbba4d90f63ed9dda7877f.tar.bz2
gentoo-2-75a6ec707d4d3143f6dbba4d90f63ed9dda7877f.zip
Version bump. Add ruby21. Add tests.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection')
-rw-r--r--dev-ruby/ruby-gobject-introspection/ChangeLog8
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.2.ebuild27
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/ChangeLog b/dev-ruby/ruby-gobject-introspection/ChangeLog
index d9cfa0cd6fd8..5f0e8c10bc4c 100644
--- a/dev-ruby/ruby-gobject-introspection/ChangeLog
+++ b/dev-ruby/ruby-gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-gobject-introspection
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gobject-introspection/ChangeLog,v 1.6 2014/08/17 10:08:27 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gobject-introspection/ChangeLog,v 1.7 2014/10/17 01:03:26 mrueg Exp $
+
+*ruby-gobject-introspection-2.2.2 (17 Oct 2014)
+
+ 17 Oct 2014; Manuel Rüger <mrueg@gentoo.org>
+ +ruby-gobject-introspection-2.2.2.ebuild:
+ Version bump. Add ruby21. Add tests.
17 Aug 2014; Anthony G. Basile <blueness@gentoo.org>
ruby-gobject-introspection-1.2.6.ebuild,
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.2.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.2.ebuild
new file mode 100644
index 000000000000..9179ed2dc774
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.2.ebuild,v 1.1 2014/10/17 01:03:26 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrosprction bindings"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+DEPEND="${DEPEND} dev-libs/gobject-introspection"
+RDEPEND="${RDEPEND} dev-libs/gobject-introspection"
+
+ruby_add_rdepend ">=dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ sed -i -e "/notify/d" test/gobject-introspection-test-utils.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}