summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-09-15 17:05:27 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-09-15 17:05:27 +0000
commit2c627472a13e1f6de72f107704af78e6e356244e (patch)
tree2c14d7e14c3b2a7bf244b0b636c237b783f3841b /dev-ruby/redcloth
parentMarked stable on x86. (diff)
downloadgentoo-2-2c627472a13e1f6de72f107704af78e6e356244e.tar.gz
gentoo-2-2c627472a13e1f6de72f107704af78e6e356244e.tar.bz2
gentoo-2-2c627472a13e1f6de72f107704af78e6e356244e.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/ChangeLog7
-rw-r--r--dev-ruby/redcloth/Manifest12
-rw-r--r--dev-ruby/redcloth/files/digest-redcloth-3.0.41
-rw-r--r--dev-ruby/redcloth/redcloth-3.0.4.ebuild35
4 files changed, 44 insertions, 11 deletions
diff --git a/dev-ruby/redcloth/ChangeLog b/dev-ruby/redcloth/ChangeLog
index 3abbe3857d25..e75c9c394f1b 100644
--- a/dev-ruby/redcloth/ChangeLog
+++ b/dev-ruby/redcloth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/redcloth
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.6 2005/09/15 16:59:12 citizen428 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.7 2005/09/15 17:05:27 citizen428 Exp $
+
+*redcloth-3.0.4 (15 Sep 2005)
+
+ 15 Sep 2005; Michael Kohl <citizen428@gentoo.org> +redcloth-3.0.4.ebuild:
+ Version bump.
15 Sep 2005; Michael Kohl <citizen428@gentoo.org> redcloth-3.0.3.ebuild:
Marked stable on x86.
diff --git a/dev-ruby/redcloth/Manifest b/dev-ruby/redcloth/Manifest
index 191bbf0be0b9..d82861a02940 100644
--- a/dev-ruby/redcloth/Manifest
+++ b/dev-ruby/redcloth/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 629b6b0650d789d3a751e179aa2b6190 redcloth-3.0.4.ebuild 831
MD5 10b50a9c23f221a53d195044d0377f4a redcloth-3.0.3.ebuild 947
MD5 3e00e28c5c17d325b223d7212d4c0366 ChangeLog 1099
MD5 1a24e0b48460c02e20931fceded24e1a metadata.xml 254
MD5 579dbfc457f6f2e8e8974f5043227e9c redcloth-3.0.2.ebuild 913
MD5 b9838cf4682185a89eca06878760ad48 files/digest-redcloth-3.0.2 65
MD5 063890b46cdc8872cd1fcc32263e3b21 files/digest-redcloth-3.0.3 62
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDKal7ehlBotwFZuQRAr2nAJ4zrWidJDRBQuWj5W1P25C8sMrz6gCeIl+G
-TnM/PCkR7+FlJ7tT98+2XYw=
-=Qop2
------END PGP SIGNATURE-----
+MD5 97fce9cd86a27c0e77672b1eeeb8bab9 files/digest-redcloth-3.0.4 62
diff --git a/dev-ruby/redcloth/files/digest-redcloth-3.0.4 b/dev-ruby/redcloth/files/digest-redcloth-3.0.4
new file mode 100644
index 000000000000..6f25df4ac129
--- /dev/null
+++ b/dev-ruby/redcloth/files/digest-redcloth-3.0.4
@@ -0,0 +1 @@
+MD5 5f010d2f42c5117e2b1c6486ceb46c02 RedCloth-3.0.4.gem 41984
diff --git a/dev-ruby/redcloth/redcloth-3.0.4.ebuild b/dev-ruby/redcloth/redcloth-3.0.4.ebuild
new file mode 100644
index 000000000000..c78d41eba32d
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-3.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.4.ebuild,v 1.1 2005/09/15 17:05:27 citizen428 Exp $
+
+inherit ruby gems
+
+MY_P="RedCloth-${PV}"
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://www.whytheluckystiff.net/ruby/redcloth/"
+SRC_URI="http://gems.rubyforge.org/gems/${MY_P}.gem"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+USE_RUBY="any"
+DEPEND="virtual/ruby"
+
+S=${WORKDIR}/${MY_P}
+
+
+pkg_postinst() {
+ einfo "NOTE: This package is now installed via a 'gem'."
+ einfo "Previous versions used a standard tarball."
+ einfo "No packages in portage required ${PN}, so you won't be affected unless"
+ einfo "you have written ruby code which requires ${PN}. In that case you'll need"
+ einfo "to add this:"
+ einfo
+ einfo "require 'rubygems'"
+ einfo
+ einfo "before:"
+ einfo "require '${PN}'"
+}
+