summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-30 07:32:42 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-30 07:32:42 +0000
commitd807823a53eda1dabf49e26771fdad601b23542d (patch)
treef67b7f047087c3a3a1b99cff4b10877331889ad9 /dev-ruby/rdoc
parentVersion bump (bug #349087 by Peter Volkov) and remove old. Add sqlite USE fla... (diff)
downloadgentoo-2-d807823a53eda1dabf49e26771fdad601b23542d.tar.gz
gentoo-2-d807823a53eda1dabf49e26771fdad601b23542d.tar.bz2
gentoo-2-d807823a53eda1dabf49e26771fdad601b23542d.zip
Version bump: more bug fixes.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rdoc')
-rw-r--r--dev-ruby/rdoc/ChangeLog7
-rw-r--r--dev-ruby/rdoc/rdoc-3.2.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-ruby/rdoc/ChangeLog b/dev-ruby/rdoc/ChangeLog
index fa009b0dc52c..997059fd0861 100644
--- a/dev-ruby/rdoc/ChangeLog
+++ b/dev-ruby/rdoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rdoc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.42 2010/12/28 08:31:39 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.43 2010/12/30 07:32:42 graaff Exp $
+
+*rdoc-3.2 (30 Dec 2010)
+
+ 30 Dec 2010; Hans de Graaff <graaff@gentoo.org> +rdoc-3.2.ebuild:
+ Version bump: more bug fixes.
28 Dec 2010; Fabian Groffen <grobian@gentoo.org> rdoc-3.0.1-r1.ebuild:
Marked ~x64-solaris
diff --git a/dev-ruby/rdoc/rdoc-3.2.ebuild b/dev-ruby/rdoc/rdoc-3.2.ebuild
new file mode 100644
index 000000000000..42e04f8eaf70
--- /dev/null
+++ b/dev-ruby/rdoc/rdoc-3.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/rdoc-3.2.ebuild,v 1.1 2010/12/30 07:32:42 graaff Exp $
+
+EAPI=3
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt RI.txt"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
+HOMEPAGE="http://rubyforge.org/projects/rdoc/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/hoe-2.7.0 )
+ test? (
+ >=dev-ruby/hoe-2.7.0
+ dev-ruby/minitest
+ )"
+
+# This ebuild replaces rdoc in ruby-1.9.2 and later.
+# ruby 1.8.6 is no longer supported.
+RDEPEND="${RDEPEND}
+ ruby_targets_ruby19? (
+ >=dev-lang/ruby-1.9.2
+ )
+ ruby_targets_ruby18? (
+ >=dev-lang/ruby-1.8.7
+ )"
+
+all_ruby_prepare() {
+ # Other packages also have use for a nonexistent directory, bug 321059
+ sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/test_rdoc*.rb || die
+
+ # Remove unavailable and unneeded isolate plugin for Hoe
+ sed -i -e '/isolate/d' Rakefile || die
+
+ epatch "${FILESDIR}/${PN}-3.0.1-bin-require.patch"
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Remove tests that will fail due to a bug in JRuby affecting
+ # Dir.mktmpdir: http://jira.codehaus.org/browse/JRUBY-4082
+ rm test/test_rdoc_options.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for bin in rdoc ri; do
+ ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
+
+ if use ruby_targets_ruby19; then
+ ruby_fakegem_binwrapper $bin /usr/bin/${bin}19
+ sed -i -e "1s/env ruby/ruby19/" \
+ "${ED}/usr/bin/${bin}19" || die
+ fi
+ done
+}