summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-10-24 12:23:04 +0000
committerHans de Graaff <graaff@gentoo.org>2008-10-24 12:23:04 +0000
commitb73ff428c3b85a71428c2a8bb0c6cc0d7c3e7625 (patch)
tree58b959e3959e6607015b3035f69630321ecf5ca4 /dev-ruby/rails
parentVersion bump for Rails 2.1.2 (diff)
downloadgentoo-2-b73ff428c3b85a71428c2a8bb0c6cc0d7c3e7625.tar.gz
gentoo-2-b73ff428c3b85a71428c2a8bb0c6cc0d7c3e7625.tar.bz2
gentoo-2-b73ff428c3b85a71428c2a8bb0c6cc0d7c3e7625.zip
Version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog8
-rw-r--r--dev-ruby/rails/rails-2.1.2.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index fd9749b559da..b698308ffdf2 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.113 2008/10/20 19:35:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.114 2008/10/24 12:23:04 graaff Exp $
+
+*rails-2.1.2 (24 Oct 2008)
+
+ 24 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.2.ebuild:
+ Version bump. Fixes security issue #242914 (header-injection) and #237285.
+ Also features minor fixes.
*rails-2.0.5 (20 Oct 2008)
diff --git a/dev-ruby/rails/rails-2.1.2.ebuild b/dev-ruby/rails/rails-2.1.2.ebuild
new file mode 100644
index 000000000000..2c53662f97bc
--- /dev/null
+++ b/dev-ruby/rails/rails-2.1.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.1.2.ebuild,v 1.1 2008/10/24 12:23:04 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.5
+ >=app-admin/eselect-rails-0.12
+ >=dev-ruby/rake-0.8.1
+ ~dev-ruby/activerecord-2.1.2
+ ~dev-ruby/activeresource-2.1.2
+ ~dev-ruby/activesupport-2.1.2
+ ~dev-ruby/actionmailer-2.1.2
+ ~dev-ruby/actionpack-2.1.2
+ !<dev-ruby/rails-1.1.6-r1"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+ # Bring users to rails 2.1.x by default when updating
+ eselect rails update 2.1
+
+ ewarn "All database USE flags have been moved to dev-ruby/activerecord"
+}
+
+pkg_postrm() {
+ # Drop users back to rails 2.0.x when they remove 2.1.x
+ eselect rails update 2
+}