summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-17 18:35:31 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-17 18:35:31 +0000
commit76855f9927e059d709d046f1f013d6bde0e2cc25 (patch)
tree3a0dbcee6184a7277394042f21fdb4fd3c236471 /dev-ruby/rails
parentlibdrm-2.4.18 version bump (diff)
downloadgentoo-2-76855f9927e059d709d046f1f013d6bde0e2cc25.tar.gz
gentoo-2-76855f9927e059d709d046f1f013d6bde0e2cc25.tar.bz2
gentoo-2-76855f9927e059d709d046f1f013d6bde0e2cc25.zip
Install more files so that creating a new project works again, fixing #303581.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog8
-rw-r--r--dev-ruby/rails/rails-2.3.5-r2.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 9bc54172efea..2dea606b713f 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.170 2010/02/13 20:47:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.171 2010/02/17 18:35:31 graaff Exp $
+
+*rails-2.3.5-r2 (17 Feb 2010)
+
+ 17 Feb 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.5-r2.ebuild:
+ Install more files so that creating a new project works again, fixing
+ #303581.
13 Feb 2010; Raúl Porcel <armin76@gentoo.org> rails-2.3.5-r1.ebuild:
Add ~ia64/~sparc
diff --git a/dev-ruby/rails/rails-2.3.5-r2.ebuild b/dev-ruby/rails/rails-2.3.5-r2.ebuild
new file mode 100644
index 000000000000..e80810905b5f
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.5-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.5-r2.ebuild,v 1.1 2010/02/17 18:35:31 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+ruby_add_bdepend doc dev-ruby/redcloth
+ruby_add_bdepend test dev-ruby/mocha
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ # fails for missing template when using the gem distribution
+ #if use doc; then
+ # pushd guides
+ # ruby rails_guides.rb || die "guide generation failed"
+ # popd
+ #fi
+}
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ #pushd guides/output
+ #docinto guides
+ #dohtml -r *
+ #popd
+
+ pushd doc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}