summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-01-20 13:41:55 +0000
committerHans de Graaff <graaff@gentoo.org>2013-01-20 13:41:55 +0000
commit0d7ed57622addc485950ed6d82dc5641232af5d7 (patch)
treed078d7aff50e2934463d8733c85b87983d6667f4 /dev-ruby/pry
parentRemove useflag dri from default linux profile settings (diff)
downloadgentoo-2-0d7ed57622addc485950ed6d82dc5641232af5d7.tar.gz
gentoo-2-0d7ed57622addc485950ed6d82dc5641232af5d7.tar.bz2
gentoo-2-0d7ed57622addc485950ed6d82dc5641232af5d7.zip
Version bump. Drop ruby18 since it no longer seems to be supported and move this version into a separate slot to allow parallel ruby18 and ruby19 versions if needed.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/pry')
-rw-r--r--dev-ruby/pry/ChangeLog11
-rw-r--r--dev-ruby/pry/pry-0.9.11.4.ebuild37
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-ruby/pry/ChangeLog b/dev-ruby/pry/ChangeLog
index d84041bbd231..9277d5cf0434 100644
--- a/dev-ruby/pry/ChangeLog
+++ b/dev-ruby/pry/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/pry
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pry/ChangeLog,v 1.10 2012/11/14 07:16:28 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pry/ChangeLog,v 1.11 2013/01/20 13:41:55 graaff Exp $
+
+*pry-0.9.11.4 (20 Jan 2013)
+
+ 20 Jan 2013; Hans de Graaff <graaff@gentoo.org> +pry-0.9.11.4.ebuild:
+ Version bump. Drop ruby18 since it no longer seems to be supported and move
+ this version into a separate slot to allow parallel ruby18 and ruby19
+ versions if needed.
14 Nov 2012; Hans de Graaff <graaff@gentoo.org> +pry-0.9.7.4-r1.ebuild:
Revision bump to depend on the right slot of slop, and to actually write the
diff --git a/dev-ruby/pry/pry-0.9.11.4.ebuild b/dev-ruby/pry/pry-0.9.11.4.ebuild
new file mode 100644
index 000000000000..98bc5ff928c4
--- /dev/null
+++ b/dev-ruby/pry/pry-0.9.11.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pry/pry-0.9.11.4.ebuild,v 1.1 2013/01/20 13:41:55 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby."
+HOMEPAGE="https://github.com/pry/pry/wiki"
+IUSE=""
+SLOT="ruby19"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/coderay-1.0.5
+ >=dev-ruby/slop-3.4.1:3
+ >=dev-ruby/method_source-0.8"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1 >=dev-ruby/open4-1.3 )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ispec -q spec/*_spec.rb spec/*/*_spec.rb || die
+}