summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-03-14 21:41:51 +0000
committerHans de Graaff <graaff@gentoo.org>2011-03-14 21:41:51 +0000
commit426515e8311673d2d690439306767e1bdc3fe6fe (patch)
tree8ee09a78560158c7b66b2cb153d29259f1f08e22 /dev-ruby/pg
parentMarked ~x86-linux (diff)
downloadgentoo-2-426515e8311673d2d690439306767e1bdc3fe6fe.tar.gz
gentoo-2-426515e8311673d2d690439306767e1bdc3fe6fe.tar.bz2
gentoo-2-426515e8311673d2d690439306767e1bdc3fe6fe.zip
Tests can only be run with FEATURES=userpriv.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/ChangeLog6
-rw-r--r--dev-ruby/pg/pg-0.10.1.ebuild15
-rw-r--r--dev-ruby/pg/pg-0.9.0-r1.ebuild16
3 files changed, 26 insertions, 11 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index 863cf5f0a5d6..c3a8ba7f1c49 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.27 2011/03/13 16:06:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.28 2011/03/14 21:41:51 graaff Exp $
+
+ 14 Mar 2011; Hans de Graaff <graaff@gentoo.org> pg-0.9.0-r1.ebuild,
+ pg-0.10.1.ebuild:
+ Tests can only be run with FEATURES=userpriv.
13 Mar 2011; Hans de Graaff <graaff@gentoo.org> pg-0.9.0-r1.ebuild:
Drop ruby19 to create a stable candidate.
diff --git a/dev-ruby/pg/pg-0.10.1.ebuild b/dev-ruby/pg/pg-0.10.1.ebuild
index 6f7dfca4e100..027a616f60f6 100644
--- a/dev-ruby/pg/pg-0.10.1.ebuild
+++ b/dev-ruby/pg/pg-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.10.1.ebuild,v 1.2 2011/01/22 07:45:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.10.1.ebuild,v 1.3 2011/03/14 21:41:51 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18 ruby19"
@@ -48,8 +48,13 @@ each_ruby_compile() {
}
each_ruby_test() {
- # Make the rspec call explicit, this way we don't have to depend
- # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
- # the whole extension from scratch.
- ${RUBY} -Ilib -S rspec -fs spec/*_spec.rb || die "spec failed"
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ ${RUBY} -Ilib -S rspec -fs spec/*_spec.rb || die "spec failed"
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
}
diff --git a/dev-ruby/pg/pg-0.9.0-r1.ebuild b/dev-ruby/pg/pg-0.9.0-r1.ebuild
index 7320c17b189b..db91f80cf25f 100644
--- a/dev-ruby/pg/pg-0.9.0-r1.ebuild
+++ b/dev-ruby/pg/pg-0.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.10 2011/03/13 16:06:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.11 2011/03/14 21:41:51 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18"
@@ -51,8 +51,14 @@ each_ruby_compile() {
}
each_ruby_test() {
- # Make the rspec call explicit, this way we don't have to depend
- # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
- # the whole extension from scratch.
- ${RUBY} -Ilib -S spec -Du -fs spec/*_spec.rb || die "spec failed"
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ ${RUBY} -Ilib -S spec -Du -fs spec/*_spec.rb || die "spec failed"
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
}
+