summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-12 23:58:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-12 23:58:20 +0000
commit25097a040dc13d25e59ce3d5949ae6d2881f47c7 (patch)
tree9d57ee186707b86a34c1cece288a0981cd56f329 /dev-ruby/parsetree
parentadd prefix support (bug #431146) (diff)
downloadgentoo-2-25097a040dc13d25e59ce3d5949ae6d2881f47c7.tar.gz
gentoo-2-25097a040dc13d25e59ce3d5949ae6d2881f47c7.tar.bz2
gentoo-2-25097a040dc13d25e59ce3d5949ae6d2881f47c7.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/parsetree')
-rw-r--r--dev-ruby/parsetree/ChangeLog8
-rw-r--r--dev-ruby/parsetree/parsetree-3.0.9.ebuild87
2 files changed, 93 insertions, 2 deletions
diff --git a/dev-ruby/parsetree/ChangeLog b/dev-ruby/parsetree/ChangeLog
index 6929d9f0f38f..adc8552e7181 100644
--- a/dev-ruby/parsetree/ChangeLog
+++ b/dev-ruby/parsetree/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/parsetree
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/ChangeLog,v 1.47 2012/04/09 13:15:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/ChangeLog,v 1.48 2012/08/12 23:58:20 flameeyes Exp $
+
+*parsetree-3.0.9 (12 Aug 2012)
+
+ 12 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +parsetree-3.0.9.ebuild:
+ Version bump.
09 Apr 2012; Hans de Graaff <graaff@gentoo.org> parsetree-3.0.8.ebuild:
Account for new ruby-inline paths and adjust dependency accordingly. Fixes
@@ -197,4 +202,3 @@
13 Apr 2007; Robin H. Johnson <robbat2@gentoo.org>
+parsetree-1.7.0.ebuild:
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
-
diff --git a/dev-ruby/parsetree/parsetree-3.0.9.ebuild b/dev-ruby/parsetree/parsetree-3.0.9.ebuild
new file mode 100644
index 000000000000..074f0350eef0
--- /dev/null
+++ b/dev-ruby/parsetree/parsetree-3.0.9.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/parsetree-3.0.9.ebuild,v 1.1 2012/08/12 23:58:20 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_NAME="ParseTree"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="ParseTree extracts the parse tree for a Class or method and returns it as a s-expression."
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/ParseTree/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend '
+ >=dev-ruby/ruby-inline-3.10.0
+ >=dev-ruby/sexp-processor-3.0.0'
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest
+ dev-ruby/ruby2ruby
+ )
+ doc? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ )"
+
+all_ruby_prepare() {
+ # Fix USE=doc by removing the path that triggers running the tests
+ # and thus building the extensions in the wrong way.
+ sed -i -e '/require_paths/d' Rakefile || die
+
+}
+
+each_ruby_prepare() {
+ # RubyInline employs a very stupid caching strategy solely based on
+ # the public signatures of methods. Never mind bugs within the C
+ # code... We add a dynamic method name to the parsetree interface
+ # just so that we can guarantee compilation. Fixes #329497.
+ epatch "${FILESDIR}/${PN}-3.0.6-timestamp.patch"
+ sed -i -e "s/TIMESTAMP/$(date +%s)/" lib/parse_tree.rb || die
+}
+
+src_compile() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+each_ruby_compile() {
+ # The ruby extension uses RubyInline to use C code within Ruby;
+ # since it causes us no little pain, we'll do our best here to
+ # prebuild the extensions.
+
+ INLINEDIR="${PWD}" ${RUBY} -Ilib -rparse_tree -e '' || die "Unable to load ${PN}"
+
+ mkdir lib/inline
+ cp .ruby_inline/*/*$(get_modname) lib/inline/ || die
+}
+
+src_test() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+pkg_postinst() {
+ elog "${CATEGORY}/${PN} uses the RubyInline library to build its parser."
+ elog "RubyInline builds loadable extensions at runtime in your home"
+ elog "directory if they are not supplied by the gems."
+ elog ""
+ elog "We are currently providing you with pre-built extensions for"
+ elog "the Ruby implementations you're using. Unfortunately these are"
+ elog "different from version to version, so you might have to"
+ elog "rebuild ${CATEGORY}/${PN} after each update to dev-lang/ruby or"
+ elog "dev-lang/ruby-enterprise."
+}