summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-04 14:14:14 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-04 14:14:14 +0000
commitb9d8f99f2a63105d839ffa3c4078facf9288533b (patch)
tree64801215fabee2bdd97ef62e9f0caca22ab7cfc8 /dev-ruby/oauth
parentStable on amd64 wrt bug #428756 (diff)
downloadgentoo-2-b9d8f99f2a63105d839ffa3c4078facf9288533b.tar.gz
gentoo-2-b9d8f99f2a63105d839ffa3c4078facf9288533b.tar.bz2
gentoo-2-b9d8f99f2a63105d839ffa3c4078facf9288533b.zip
Add ruby19. Avoid dependency on old actionpack since we don't have that marked for ruby19 and the remainder of the code works.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/ChangeLog6
-rw-r--r--dev-ruby/oauth/oauth-0.4.6.ebuild14
2 files changed, 16 insertions, 4 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index 1c03ed46a37b..96e74caffdcb 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/oauth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.18 2012/08/04 09:45:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.19 2012/08/04 14:14:14 graaff Exp $
+
+ 04 Aug 2012; Hans de Graaff <graaff@gentoo.org> oauth-0.4.6.ebuild:
+ Add ruby19. Avoid dependency on old actionpack since we don't have that
+ marked for ruby19 and the remainder of the code works.
04 Aug 2012; Hans de Graaff <graaff@gentoo.org> -oauth-0.4.4.ebuild,
-oauth-0.4.5.ebuild:
diff --git a/dev-ruby/oauth/oauth-0.4.6.ebuild b/dev-ruby/oauth/oauth-0.4.6.ebuild
index 51327b3f869e..a535cd026367 100644
--- a/dev-ruby/oauth/oauth-0.4.6.ebuild
+++ b/dev-ruby/oauth/oauth-0.4.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.6.ebuild,v 1.1 2012/05/18 06:43:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.6.ebuild,v 1.2 2012/08/04 14:14:14 graaff Exp $
EAPI="2"
-USE_RUBY="ruby18 ree18"
+USE_RUBY="ruby18 ree18 ruby19"
RUBY_FAKEGEM_TASK_DOC=""
@@ -20,9 +20,9 @@ KEYWORDS="~amd64 ~x86 ~x86-macos"
IUSE=""
ruby_add_bdepend "test? (
- >=dev-ruby/actionpack-2.3.8:2.3
dev-ruby/mocha
dev-ruby/webmock )"
+USE_RUBY="ruby18 ree18" ruby_add_bdepend "test? ( >=dev-ruby/actionpack-2.3.8:2.3 )"
all_ruby_prepare() {
# Ensure a consistent test order to avoid loading issues with e.g. rack
@@ -35,6 +35,14 @@ each_ruby_prepare() {
# Ignore hash ordering test failures
sed -i -e '183s:^:#:' -e '224s:^:#:' test/integration/consumer_test.rb || die
;;
+ *rubyee18)
+ # Ignore hash ordering test failures
+ sed -i -e '183s:^:#:' -e '224s:^:#:' test/integration/consumer_test.rb || die
+ ;;
+ *ruby19)
+ # Remove tests depending on rails.
+ rm test/test_action_controller_request_proxy.rb || die
+ ;;
*)
;;
esac