summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-18 06:43:03 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-18 06:43:03 +0000
commit5388ed56c1b2780969fe5a3d2dd26e18853478c9 (patch)
treeb4bbdea7aed0c38a9d3676feb2fb83a24e728481 /dev-ruby/oauth
parentMarked ~ppc ~ppc64 for bug #402989. (diff)
downloadgentoo-2-5388ed56c1b2780969fe5a3d2dd26e18853478c9.tar.gz
gentoo-2-5388ed56c1b2780969fe5a3d2dd26e18853478c9.tar.bz2
gentoo-2-5388ed56c1b2780969fe5a3d2dd26e18853478c9.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/ChangeLog9
-rw-r--r--dev-ruby/oauth/oauth-0.4.6.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index 7597d40b5cb3..74b5ed6e1528 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.16 2011/06/26 07:12:23 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.17 2012/05/18 06:43:02 graaff Exp $
+
+*oauth-0.4.6 (18 May 2012)
+
+ 18 May 2012; Hans de Graaff <graaff@gentoo.org> +oauth-0.4.6.ebuild:
+ Version bump.
*oauth-0.4.5 (26 Jun 2011)
diff --git a/dev-ruby/oauth/oauth-0.4.6.ebuild b/dev-ruby/oauth/oauth-0.4.6.ebuild
new file mode 100644
index 000000000000..51327b3f869e
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.4.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.6.ebuild,v 1.1 2012/05/18 06:43:03 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers."
+HOMEPAGE="http://oauth.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/actionpack-2.3.8:2.3
+ dev-ruby/mocha
+ dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ # Ensure a consistent test order to avoid loading issues with e.g. rack
+ sed -i -e "s/.rb']/.rb'].sort/" Rakefile || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby18)
+ # Ignore hash ordering test failures
+ sed -i -e '183s:^:#:' -e '224s:^:#:' test/integration/consumer_test.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}