summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-20 15:00:43 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-20 15:00:43 +0000
commit8423748f76b8e95258a26e05e59ca90b32ae0ac9 (patch)
tree920f295082897816f54b06b89b76238bf39022bf /dev-ruby/niceogiri
parentAdd jruby target. Cleanup old. (diff)
downloadgentoo-2-8423748f76b8e95258a26e05e59ca90b32ae0ac9.tar.gz
gentoo-2-8423748f76b8e95258a26e05e59ca90b32ae0ac9.tar.bz2
gentoo-2-8423748f76b8e95258a26e05e59ca90b32ae0ac9.zip
Initial ebuild.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/niceogiri')
-rw-r--r--dev-ruby/niceogiri/ChangeLog9
-rw-r--r--dev-ruby/niceogiri/metadata.xml5
-rw-r--r--dev-ruby/niceogiri/niceogiri-1.1.2.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/niceogiri/ChangeLog b/dev-ruby/niceogiri/ChangeLog
new file mode 100644
index 000000000000..80e919f4f81d
--- /dev/null
+++ b/dev-ruby/niceogiri/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-ruby/niceogiri
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/niceogiri/ChangeLog,v 1.1 2013/11/20 15:00:43 mrueg Exp $
+
+*niceogiri-1.1.2 (20 Nov 2013)
+
+ 20 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +metadata.xml,
+ +niceogiri-1.1.2.ebuild:
+ Initial ebuild.
diff --git a/dev-ruby/niceogiri/metadata.xml b/dev-ruby/niceogiri/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/niceogiri/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/niceogiri/niceogiri-1.1.2.ebuild b/dev-ruby/niceogiri/niceogiri-1.1.2.ebuild
new file mode 100644
index 000000000000..33ad39459a19
--- /dev/null
+++ b/dev-ruby/niceogiri/niceogiri-1.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/niceogiri/niceogiri-1.1.2.ebuild,v 1.1 2013/11/20 15:00:43 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Some wrappers around and helpers for XML manipulation using Nokogiri"
+HOMEPAGE="https://github.com/benlangfeld/Niceogiri"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/nokogiri"
+
+all_ruby_prepare() {
+ sed -i -e '/guard-rspec/d' ${PN}.gemspec || die
+}