summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-09 07:50:49 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-09 07:50:49 +0000
commit288be0e9c8c5d486efe090d0791266d6297d948a (patch)
tree4c3004956a20fe56bbc7ab83bd66d61cc6e5557a /dev-ruby/narray
parentFix building for x32 targets #420239 by Xavier Miller. (diff)
downloadgentoo-2-288be0e9c8c5d486efe090d0791266d6297d948a.tar.gz
gentoo-2-288be0e9c8c5d486efe090d0791266d6297d948a.tar.bz2
gentoo-2-288be0e9c8c5d486efe090d0791266d6297d948a.zip
Revision bump to also install the header files for the compiled extension, bug 420319.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/narray')
-rw-r--r--dev-ruby/narray/ChangeLog8
-rw-r--r--dev-ruby/narray/narray-0.6.0.1-r2.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/narray/ChangeLog b/dev-ruby/narray/ChangeLog
index f2019a8fe788..33a9b3320ba7 100644
--- a/dev-ruby/narray/ChangeLog
+++ b/dev-ruby/narray/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/narray
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.50 2012/02/06 19:18:53 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.51 2012/06/09 07:50:49 graaff Exp $
+
+*narray-0.6.0.1-r2 (09 Jun 2012)
+
+ 09 Jun 2012; Hans de Graaff <graaff@gentoo.org> +narray-0.6.0.1-r2.ebuild:
+ Revision bump to also install the header files for the compiled extension,
+ bug 420319.
06 Feb 2012; Brent Baude <ranger@gentoo.org> narray-0.6.0.1.ebuild:
Marking narray-0.6.0.1 ppc for bug 386135
diff --git a/dev-ruby/narray/narray-0.6.0.1-r2.ebuild b/dev-ruby/narray/narray-0.6.0.1-r2.ebuild
new file mode 100644
index 000000000000..a32256c8f38d
--- /dev/null
+++ b/dev-ruby/narray/narray-0.6.0.1-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.1-r2.ebuild,v 1.1 2012/06/09 07:50:49 graaff Exp $
+
+EAPI=4
+
+# jruby → native extension
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.en README.ja SPEC.en SPEC.ja"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="mirror://rubyforge/${PN}/${P/_/}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those ad
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
+ cp -l ${PN}$(get_modname) ${PN}.h ${PN}_config.h lib/ || die "copy of ${PN}$(get_modname) failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ # Skip over the FFTW test because it needs a package we don't
+ # have in tree.
+ [[ ${unit} == test/testfftw.rb ]] && continue
+
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}