summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-05 23:03:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-05 23:03:34 +0000
commit23708b949361a50fc76f78ad21950e5b55834f9c (patch)
tree803f841da072ec06920276b962df67e4adc74691 /dev-ruby/multi_json
parentVersion bump. (diff)
downloadgentoo-2-23708b949361a50fc76f78ad21950e5b55834f9c.tar.gz
gentoo-2-23708b949361a50fc76f78ad21950e5b55834f9c.tar.bz2
gentoo-2-23708b949361a50fc76f78ad21950e5b55834f9c.zip
Version bump, use the new rspec support.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/ChangeLog8
-rw-r--r--dev-ruby/multi_json/multi_json-1.3.6.ebuild51
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 98882855371a..8b1af68789e0 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.20 2012/05/17 11:45:37 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.21 2012/07/05 23:03:34 flameeyes Exp $
+
+*multi_json-1.3.6 (05 Jul 2012)
+
+ 05 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +multi_json-1.3.6.ebuild:
+ Version bump, use the new rspec support.
*multi_json-1.3.5 (17 May 2012)
@@ -91,4 +96,3 @@
Initial import of multi_json needed for the new version of oauth2. The
tests are particularly patched (and not all of it is upstreamed yet) so
that they pass on Ruby 1.9 and JRuby properly.
-
diff --git a/dev-ruby/multi_json/multi_json-1.3.6.ebuild b/dev-ruby/multi_json/multi_json-1.3.6.ebuild
new file mode 100644
index 000000000000..9d59b26343f3
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.3.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.3.6.ebuild,v 1.1 2012/07/05 23:03:34 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="http://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
+
+ruby_add_bdepend "test? ( dev-ruby/json )"
+
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
+ rm Gemfile || die "Unable to remove bundler Gemfile."
+
+ # Provide version otherwise provided by bundler.
+ sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove best default spec since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}