summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-11 06:00:04 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-11 06:00:04 +0000
commita5661cf0aeb07c575a345c1c106089ee1a8c5fc2 (patch)
tree5f3217513668778b8269526097a32b0c3e1a3413 /dev-ruby/json
parentVersion bump. (diff)
downloadgentoo-2-a5661cf0aeb07c575a345c1c106089ee1a8c5fc2.tar.gz
gentoo-2-a5661cf0aeb07c575a345c1c106089ee1a8c5fc2.tar.bz2
gentoo-2-a5661cf0aeb07c575a345c1c106089ee1a8c5fc2.zip
Remove old versions.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog6
-rw-r--r--dev-ruby/json/json-1.5.1.ebuild63
-rw-r--r--dev-ruby/json/json-1.5.2.ebuild62
3 files changed, 5 insertions, 126 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 8403bb57deeb..7b61b6b67ab7 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.64 2011/07/15 17:32:06 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.65 2011/09/11 06:00:04 graaff Exp $
+
+ 11 Sep 2011; Hans de Graaff <graaff@gentoo.org> -json-1.5.1.ebuild,
+ -json-1.5.2.ebuild:
+ Remove old versions.
15 Jul 2011; Matt Turner <mattst88@gentoo.org> json-1.5.3.ebuild:
Added ~mips, bug 332593
diff --git a/dev-ruby/json/json-1.5.1.ebuild b/dev-ruby/json/json-1.5.1.ebuild
deleted file mode 100644
index 8acbea884faf..000000000000
--- a/dev-ruby/json/json-1.5.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.5.1.ebuild,v 1.2 2011/03/07 12:03:53 armin76 Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- sed -i \
- -e 's| => :compile_ext||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- # Since 1.5.0 a Java extension is provided but it does not compile.
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile_ext || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/*.rb || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/*.rb || die "ext ruby tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
- fi
-}
diff --git a/dev-ruby/json/json-1.5.2.ebuild b/dev-ruby/json/json-1.5.2.ebuild
deleted file mode 100644
index 715533a23a83..000000000000
--- a/dev-ruby/json/json-1.5.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.5.2.ebuild,v 1.1 2011/06/15 06:02:10 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- sed -i \
- -e 's| => :compile||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- # Since 1.5.0 a Java extension is provided but it does not compile.
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/*.rb || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/*.rb || die "ext ruby tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
- fi
-}