summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-12-04 07:19:15 +0000
committerHans de Graaff <graaff@gentoo.org>2013-12-04 07:19:15 +0000
commit6e91fbe36feb67eca23295b0005c2dabaea0c732 (patch)
treeb2846cef38fccac0ca2d1d5e1a40c65319c27c5c /dev-ruby/i18n
parentAdd ssse3 USE flag, bug 493152. (diff)
downloadgentoo-2-6e91fbe36feb67eca23295b0005c2dabaea0c732.tar.gz
gentoo-2-6e91fbe36feb67eca23295b0005c2dabaea0c732.tar.bz2
gentoo-2-6e91fbe36feb67eca23295b0005c2dabaea0c732.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/i18n')
-rw-r--r--dev-ruby/i18n/ChangeLog7
-rw-r--r--dev-ruby/i18n/i18n-0.6.9.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index bb64eba25479..1279be4f20ee 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.56 2013/11/05 07:00:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.57 2013/12/04 07:19:15 graaff Exp $
+
+*i18n-0.6.9 (04 Dec 2013)
+
+ 04 Dec 2013; Hans de Graaff <graaff@gentoo.org> +i18n-0.6.9.ebuild:
+ Version bump.
05 Nov 2013; Hans de Graaff <graaff@gentoo.org> -i18n-0.6.4.ebuild:
Cleanup.
diff --git a/dev-ruby/i18n/i18n-0.6.9.ebuild b/dev-ruby/i18n/i18n-0.6.9.ebuild
new file mode 100644
index 000000000000..7225dfa047ab
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.6.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.6.9.ebuild,v 1.1 2013/12/04 07:19:15 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 jruby ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="test"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+LICENSE="MIT"
+SLOT="0.6"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport
+ dev-ruby/mocha:0.12
+ dev-ruby/test_declarative )"
+
+each_ruby_test() {
+ ${RUBY} -w -Ilib -Itest test/all.rb || die
+}
+
+all_ruby_prepare() {
+ #Bundler isn't really necessary here, and it doesn't work with jruby
+ #Tests fail for ruby18 with >=mocha-0.13
+ sed -i -e "15s/require 'bundler\/setup'//"\
+ -e "/require 'mocha'/i gem 'mocha', '~>0.12.0'" test/test_helper.rb || die
+}