summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-11-27 07:23:05 +0000
committerHans de Graaff <graaff@gentoo.org>2014-11-27 07:23:05 +0000
commit5c53a41f8823d675a3632afab0e839cdc8809a22 (patch)
treed5316084c222943414d634d8eabdadaec3393455 /dev-ruby/http
parentVersion bump (bug #513164). (diff)
downloadgentoo-2-5c53a41f8823d675a3632afab0e839cdc8809a22.tar.gz
gentoo-2-5c53a41f8823d675a3632afab0e839cdc8809a22.tar.bz2
gentoo-2-5c53a41f8823d675a3632afab0e839cdc8809a22.zip
Version bump.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/http')
-rw-r--r--dev-ruby/http/ChangeLog7
-rw-r--r--dev-ruby/http/http-0.6.3.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/http/ChangeLog b/dev-ruby/http/ChangeLog
index 64a0bec78f15..19a512361666 100644
--- a/dev-ruby/http/ChangeLog
+++ b/dev-ruby/http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/http
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http/ChangeLog,v 1.9 2014/08/15 14:32:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http/ChangeLog,v 1.10 2014/11/27 07:23:05 graaff Exp $
+
+*http-0.6.3 (27 Nov 2014)
+
+ 27 Nov 2014; Hans de Graaff <graaff@gentoo.org> +http-0.6.3.ebuild:
+ Version bump.
15 Aug 2014; Anthony G. Basile <blueness@gentoo.org> http-0.5.0.ebuild,
http-0.6.1.ebuild, http-0.6.2.ebuild:
diff --git a/dev-ruby/http/http-0.6.3.ebuild b/dev-ruby/http/http-0.6.3.ebuild
new file mode 100644
index 000000000000..369de1ca93d5
--- /dev/null
+++ b/dev-ruby/http/http-0.6.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http/http-0.6.3.ebuild,v 1.1 2014/11/27 07:23:05 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy-to-use client library for making requests from Ruby"
+HOMEPAGE="https://github.com/tarcieri/http"
+
+LICENSE="MIT"
+SLOT="0.6"
+KEYWORDS="~amd64 ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/end/ s:^:#:' \
+ -e '1irequire "cgi"' spec/spec_helper.rb || die
+}