summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-22 08:11:15 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-22 08:11:15 +0000
commit122e0cebad73f74af678c0bb078b239740672a4b (patch)
tree9a02b397faf6ca0ed46fa2057f9cc392bb0ef9be /dev-ruby/highline
parentAdd bufexplorer.vim to MISC-FREE license group, bug 448064. Add PCRE to MISC-... (diff)
downloadgentoo-2-122e0cebad73f74af678c0bb078b239740672a4b.tar.gz
gentoo-2-122e0cebad73f74af678c0bb078b239740672a4b.tar.bz2
gentoo-2-122e0cebad73f74af678c0bb078b239740672a4b.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/highline')
-rw-r--r--dev-ruby/highline/ChangeLog7
-rw-r--r--dev-ruby/highline/highline-1.6.15.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/highline/ChangeLog b/dev-ruby/highline/ChangeLog
index 667a70f1aa1d..939891b26c6a 100644
--- a/dev-ruby/highline/ChangeLog
+++ b/dev-ruby/highline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/highline
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/ChangeLog,v 1.68 2012/12/19 16:14:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/ChangeLog,v 1.69 2012/12/22 08:11:15 graaff Exp $
+
+*highline-1.6.15 (22 Dec 2012)
+
+ 22 Dec 2012; Hans de Graaff <graaff@gentoo.org> +highline-1.6.15.ebuild:
+ Version bump.
19 Dec 2012; Jeroen Roovers <jer@gentoo.org> highline-1.6.13.ebuild:
Stable for HPPA (bug #447594).
diff --git a/dev-ruby/highline/highline-1.6.15.ebuild b/dev-ruby/highline/highline-1.6.15.ebuild
new file mode 100644
index 000000000000..2cf4ba949d3c
--- /dev/null
+++ b/dev-ruby/highline/highline-1.6.15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/highline-1.6.15.ebuild,v 1.1 2012/12/22 08:11:15 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby."
+HOMEPAGE="http://highline.rubyforge.org/"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ sed -i -e '/\(tc_highline\|tc_menu\)/ s:^:#:' test/ts_all.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Skipping tests since they hang indefinitely."
+ ;;
+ *)
+ ${RUBY} -S rake test || die
+ ;;
+ esac
+}