summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-04-05 02:29:30 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-04-05 02:29:30 +0000
commit3e596c052b9cd0125522475a6c1c1ca901ec6c65 (patch)
treefb37f4878cff63da3788d0a129c75cb6e09ec5b9 /dev-ruby/hiera
parentClean old impls, add py3.4 support (diff)
downloadgentoo-2-3e596c052b9cd0125522475a6c1c1ca901ec6c65.tar.gz
gentoo-2-3e596c052b9cd0125522475a6c1c1ca901ec6c65.tar.bz2
gentoo-2-3e596c052b9cd0125522475a6c1c1ca901ec6c65.zip
bup
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-ruby/hiera')
-rw-r--r--dev-ruby/hiera/ChangeLog7
-rw-r--r--dev-ruby/hiera/hiera-2.0.0.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/hiera/ChangeLog b/dev-ruby/hiera/ChangeLog
index eadbb60ab94c..f85fb6ec79dc 100644
--- a/dev-ruby/hiera/ChangeLog
+++ b/dev-ruby/hiera/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hiera
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/ChangeLog,v 1.32 2015/03/12 06:52:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/ChangeLog,v 1.33 2015/04/05 02:29:30 prometheanfire Exp $
+
+*hiera-2.0.0 (05 Apr 2015)
+
+ 05 Apr 2015; Matthew Thode <prometheanfire@gentoo.org> +hiera-2.0.0.ebuild:
+ bup
12 Mar 2015; Hans de Graaff <graaff@gentoo.org> -hiera-1.2.1.ebuild:
Cleanup.
diff --git a/dev-ruby/hiera/hiera-2.0.0.ebuild b/dev-ruby/hiera/hiera-2.0.0.ebuild
new file mode 100644
index 000000000000..4971eaf79733
--- /dev/null
+++ b/dev-ruby/hiera/hiera-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/hiera-2.0.0.ebuild,v 1.1 2015/04/05 02:29:30 prometheanfire Exp $
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="http://projects.puppetlabs.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/json"
+
+all_ruby_prepare() {
+ # Our json package is either the compiled version or the pure
+ # version. Fix gemspec accordingly.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}