summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-29 07:24:51 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-29 07:24:51 +0000
commit1a35c6491a37871c59dadb83cb1f602efdd56543 (patch)
tree0ba1ec01eec4951cab8ee3e546af49493cf7ebc1 /dev-ruby/haml
parentRemove old versions. (diff)
downloadgentoo-2-1a35c6491a37871c59dadb83cb1f602efdd56543.tar.gz
gentoo-2-1a35c6491a37871c59dadb83cb1f602efdd56543.tar.bz2
gentoo-2-1a35c6491a37871c59dadb83cb1f602efdd56543.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog7
-rw-r--r--dev-ruby/haml/haml-3.1.4.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 9a8fd820d69e..518a992c4cd4 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.67 2011/11/29 07:21:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.68 2011/11/29 07:24:51 graaff Exp $
+
+*haml-3.1.4 (29 Nov 2011)
+
+ 29 Nov 2011; Hans de Graaff <graaff@gentoo.org> +haml-3.1.4.ebuild:
+ Version bump.
29 Nov 2011; Hans de Graaff <graaff@gentoo.org> -haml-3.0.24.ebuild,
-haml-3.1.1.ebuild:
diff --git a/dev-ruby/haml/haml-3.1.4.ebuild b/dev-ruby/haml/haml-3.1.4.ebuild
new file mode 100644
index 000000000000..1eb3066da89a
--- /dev/null
+++ b/dev-ruby/haml/haml-3.1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.1.4.ebuild,v 1.1 2011/11/29 07:24:51 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend "dev-ruby/hpricot dev-ruby/fssm"
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"