summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-24 13:22:09 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-24 13:22:09 +0000
commitbe908668f0c6d6b82825e636f18ebfb4a09a833e (patch)
treea35d36dab45f930a7e553b56842a866c422841c0 /dev-ruby/gherkin
parentRemove old. (diff)
downloadgentoo-2-be908668f0c6d6b82825e636f18ebfb4a09a833e.tar.gz
gentoo-2-be908668f0c6d6b82825e636f18ebfb4a09a833e.tar.bz2
gentoo-2-be908668f0c6d6b82825e636f18ebfb4a09a833e.zip
Only require yard with USE=doc. Update homepage. Both reported in bug 443708.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog5
-rw-r--r--dev-ruby/gherkin/gherkin-2.11.5.ebuild14
2 files changed, 15 insertions, 4 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 18261e2c65da..c571f2ec848a 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.45 2012/11/16 06:47:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.46 2012/11/24 13:22:09 graaff Exp $
+
+ 24 Nov 2012; Hans de Graaff <graaff@gentoo.org> gherkin-2.11.5.ebuild:
+ Only require yard with USE=doc. Update homepage. Both reported in bug 443708.
16 Nov 2012; Hans de Graaff <graaff@gentoo.org> -gherkin-2.9.3.ebuild,
-gherkin-2.10.0.ebuild:
diff --git a/dev-ruby/gherkin/gherkin-2.11.5.ebuild b/dev-ruby/gherkin/gherkin-2.11.5.ebuild
index e02774d12ae9..839ada7de823 100644
--- a/dev-ruby/gherkin/gherkin-2.11.5.ebuild
+++ b/dev-ruby/gherkin/gherkin-2.11.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.11.5.ebuild,v 1.1 2012/11/16 06:45:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.11.5.ebuild,v 1.2 2012/11/24 13:22:09 graaff Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18"
@@ -14,7 +14,7 @@ RUBY_FAKEGEM_EXTRADOC="History.md README.md"
inherit ruby-fakegem
DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
+HOMEPAGE="https://github.com/cucumber/gherkin"
LICENSE="MIT"
SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
@@ -60,13 +60,21 @@ all_ruby_prepare() {
rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
fi
+ # Avoid dependency on yard if USE=-doc
+ if ! use doc ; then
+ rm tasks/apidoc.rake || die
+ fi
+
# Avoid implicit dependency on git
sed -i -e 's/git ls-files/echo/' gherkin.gemspec || die
}
all_ruby_compile() {
all_fakegem_compile
- yard || die
+
+ if use doc ; then
+ yard || die
+ fi
}
each_ruby_compile() {