summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-10-03 12:26:28 +0000
committerAlex Legler <a3li@gentoo.org>2009-10-03 12:26:28 +0000
commit1431229e4a83c86d8c893e5fa33bfe73895d59f0 (patch)
tree1823fa5e8d21ab1120eaaf869ceabc30e4797e43 /dev-ruby/activerecord
parentVersion bump, security bug 283396 (diff)
downloadgentoo-2-1431229e4a83c86d8c893e5fa33bfe73895d59f0.tar.gz
gentoo-2-1431229e4a83c86d8c893e5fa33bfe73895d59f0.tar.bz2
gentoo-2-1431229e4a83c86d8c893e5fa33bfe73895d59f0.zip
Version bump, security bug 283396
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-2.2.3.ebuild22
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 713221e973b1..b674bb0173e7 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.111 2009/09/26 19:48:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.112 2009/10/03 12:26:28 a3li Exp $
+
+*activerecord-2.2.3 (03 Oct 2009)
+
+ 03 Oct 2009; Alex Legler <a3li@gentoo.org> +activerecord-2.2.3.ebuild:
+ Version bump, security bug 283396
26 Sep 2009; Hans de Graaff <graaff@gentoo.org>
-activerecord-2.3.2.ebuild, -activerecord-2.3.3.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-2.2.3.ebuild b/dev-ruby/activerecord/activerecord-2.2.3.ebuild
new file mode 100644
index 000000000000..d4eee1cfaaef
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.2.3.ebuild,v 1.1 2009/10/03 12:26:28 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18"
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ ~dev-ruby/activesupport-2.2.3
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"