summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-30 19:45:37 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-30 19:45:37 +0000
commitdd0dd76c96fbd8e045e68880ef17f7bffe213ded (patch)
treece8d997be38da9d6ceabf40b911c82fd8d1ceda8 /dev-ruby/actionmailer
parentVersion bump. Add ruby19. Drop arches due to bug 396547. (diff)
downloadgentoo-2-dd0dd76c96fbd8e045e68880ef17f7bffe213ded.tar.gz
gentoo-2-dd0dd76c96fbd8e045e68880ef17f7bffe213ded.tar.bz2
gentoo-2-dd0dd76c96fbd8e045e68880ef17f7bffe213ded.zip
Version bump. Add ruby19. Drop arches due to bug 396547.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.1.3.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 67652567c617..ad22546bff39 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.175 2011/11/19 11:05:28 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.176 2011/12/30 19:45:37 graaff Exp $
+
+*actionmailer-3.1.3 (30 Dec 2011)
+
+ 30 Dec 2011; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.1.3.ebuild:
+ Version bump. Add ruby19. Drop arches due to bug 396547.
*actionmailer-3.0.11 (19 Nov 2011)
diff --git a/dev-ruby/actionmailer/actionmailer-3.1.3.ebuild b/dev-ruby/actionmailer/actionmailer-3.1.3.ebuild
new file mode 100644
index 000000000000..e8ac0c17c9de
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.1.3.ebuild,v 1.1 2011/12/30 19:45:37 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.3.0"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}