summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-11 21:22:44 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-11 21:22:44 +0000
commitceca7fed5bcf823fefc36d4817cc070ee7092ed8 (patch)
treed05d299005b9b95a99df6799b3549d1807bd4e77 /dev-ruby/actionmailer
parentVersion bump for security bug 456840. (diff)
downloadgentoo-2-ceca7fed5bcf823fefc36d4817cc070ee7092ed8.tar.gz
gentoo-2-ceca7fed5bcf823fefc36d4817cc070ee7092ed8.tar.bz2
gentoo-2-ceca7fed5bcf823fefc36d4817cc070ee7092ed8.zip
Version bump for security bug 456840.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.17.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index ad8460e6bf08..7232675f8248 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.224 2013/02/11 20:47:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.225 2013/02/11 21:22:44 graaff Exp $
+
+*actionmailer-2.3.17 (11 Feb 2013)
+
+ 11 Feb 2013; Hans de Graaff <graaff@gentoo.org> +actionmailer-2.3.17.ebuild:
+ Version bump for security bug 456840.
*actionmailer-3.1.11 (11 Feb 2013)
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.17.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.17.ebuild
new file mode 100644
index 000000000000..caa225c57ffb
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.17.ebuild,v 1.1 2013/02/11 21:22:44 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-2.3.10-rails3.patch" )
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/text-format-0.6.3
+ >=dev-ruby/tmail-1.2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}