summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-11-17 20:19:39 +0000
committerHans de Graaff <graaff@gentoo.org>2014-11-17 20:19:39 +0000
commitbb61bbcfa99de06f3c813fed786a3ed648d5540e (patch)
tree0c73a1dc463ee1a9d202d9d4cde9e951d6237bf4 /dev-ruby/actionmailer
parentVersion bump for security bug 529635. (diff)
downloadgentoo-2-bb61bbcfa99de06f3c813fed786a3ed648d5540e.tar.gz
gentoo-2-bb61bbcfa99de06f3c813fed786a3ed648d5540e.tar.bz2
gentoo-2-bb61bbcfa99de06f3c813fed786a3ed648d5540e.zip
Version bump for security bug 529635.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog10
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.2.21.ebuild38
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.0.12.ebuild41
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.1.8.ebuild45
4 files changed, 133 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 34de5d14a082..7e35f201f40c 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.275 2014/11/07 10:14:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.276 2014/11/17 20:19:39 graaff Exp $
+
+*actionmailer-4.1.8 (17 Nov 2014)
+*actionmailer-4.0.12 (17 Nov 2014)
+*actionmailer-3.2.21 (17 Nov 2014)
+
+ 17 Nov 2014; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.2.21.ebuild,
+ +actionmailer-4.0.12.ebuild, +actionmailer-4.1.8.ebuild:
+ Version bump for security bug 529635.
07 Nov 2014; Hans de Graaff <graaff@gentoo.org> -actionmailer-3.2.19.ebuild,
-actionmailer-4.0.9.ebuild, -actionmailer-4.0.10.ebuild,
diff --git a/dev-ruby/actionmailer/actionmailer-3.2.21.ebuild b/dev-ruby/actionmailer/actionmailer-3.2.21.ebuild
new file mode 100644
index 000000000000..cd802ed426f3
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.2.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.2.21.ebuild,v 1.1 2014/11/17 20:19:39 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha:0.13
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|mysql\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|nokogiri\|bcrypt-ruby\|rdoc\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+}
diff --git a/dev-ruby/actionmailer/actionmailer-4.0.12.ebuild b/dev-ruby/actionmailer/actionmailer-4.0.12.ebuild
new file mode 100644
index 000000000000..416e7ca8a5f2
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.0.12.ebuild,v 1.1 2014/11/17 20:19:39 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha:0.13
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+
+ # Add json to Gemfile to fix mime-types not doing this itself.
+ sed -e '5igem "json"' -i ../Gemfile || die
+}
diff --git a/dev-ruby/actionmailer/actionmailer-4.1.8.ebuild b/dev-ruby/actionmailer/actionmailer-4.1.8.ebuild
new file mode 100644
index 000000000000..d29810adea27
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.1.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.1.8.ebuild,v 1.1 2014/11/17 20:19:39 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}