summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-05 08:59:13 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-05 08:59:13 +0000
commit88c67c64b432fd81710fa974a7decbbf2cc843dd (patch)
tree5ab03eac99d93a95aa0ef43cb00a1adca5c7c13d /dev-ruby/actionmailer
parentVersion bump for Rails 3. (diff)
downloadgentoo-2-88c67c64b432fd81710fa974a7decbbf2cc843dd.tar.gz
gentoo-2-88c67c64b432fd81710fa974a7decbbf2cc843dd.tar.bz2
gentoo-2-88c67c64b432fd81710fa974a7decbbf2cc843dd.zip
Version bump for Rails 3.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.0.3.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index e8b799a08e7e..ef18a8735568 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.147 2010/10/15 08:01:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.148 2010/12/05 08:59:13 graaff Exp $
+
+*actionmailer-3.0.3 (05 Dec 2010)
+
+ 05 Dec 2010; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-3.0.3.ebuild:
+ Version bump for Rails 3.
15 Oct 2010; Hans de Graaff <graaff@gentoo.org>
-actionmailer-2.3.9.ebuild:
diff --git a/dev-ruby/actionmailer/actionmailer-3.0.3.ebuild b/dev-ruby/actionmailer/actionmailer-3.0.3.ebuild
new file mode 100644
index 000000000000..877454dd6157
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.0.3.ebuild,v 1.1 2010/12/05 08:59:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.2.9"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}