summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-06-16 21:12:10 +0000
committerHans de Graaff <graaff@gentoo.org>2015-06-16 21:12:10 +0000
commit2c0de06828157edf30040d02f89201458e4ad46e (patch)
treea362cd094aeef3e1f440c875b4e248805508a46f /dev-ruby/actionmailer
parentVersion bump. (diff)
downloadgentoo-2-2c0de06828157edf30040d02f89201458e4ad46e.tar.gz
gentoo-2-2c0de06828157edf30040d02f89201458e4ad46e.tar.bz2
gentoo-2-2c0de06828157edf30040d02f89201458e4ad46e.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.2.22.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 7716e95732fc..7b166b5cdd6b 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.286 2015/06/07 16:37:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.287 2015/06/16 21:12:10 graaff Exp $
+
+*actionmailer-3.2.22 (16 Jun 2015)
+
+ 16 Jun 2015; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.2.22.ebuild:
+ Version bump.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-ruby/actionmailer/actionmailer-3.2.22.ebuild b/dev-ruby/actionmailer/actionmailer-3.2.22.ebuild
new file mode 100644
index 000000000000..c4b8c0d03d48
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.2.22.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.2.22.ebuild,v 1.1 2015/06/16 21:12:10 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha:0.13
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|mysql\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|nokogiri\|bcrypt-ruby\|rdoc\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+
+ # Avoid test requiring the "pl" locale.
+ sed -i -e '/implicit multipart with other locale/,/^ end/ s:^:#:' \
+ test/base_test.rb || die
+}