summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-09-12 05:55:37 +0000
committerHans de Graaff <graaff@gentoo.org>2014-09-12 05:55:37 +0000
commit2b8f40a687990974181d7370547993dbf49d86ff (patch)
tree6558904708cda94b414bf3dc9eb82bda57d74a6c /dev-ruby/actionmailer
parentVersion bump. (diff)
downloadgentoo-2-2b8f40a687990974181d7370547993dbf49d86ff.tar.gz
gentoo-2-2b8f40a687990974181d7370547993dbf49d86ff.tar.bz2
gentoo-2-2b8f40a687990974181d7370547993dbf49d86ff.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.0.10.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 6dd7604056b7..fe3a50ba1995 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.271 2014/08/23 07:02:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.272 2014/09/12 05:55:37 graaff Exp $
+
+*actionmailer-4.0.10 (12 Sep 2014)
+
+ 12 Sep 2014; Hans de Graaff <graaff@gentoo.org> +actionmailer-4.0.10.ebuild:
+ Version bump.
23 Aug 2014; Hans de Graaff <graaff@gentoo.org> -actionmailer-4.0.8.ebuild,
-actionmailer-4.1.4.ebuild:
diff --git a/dev-ruby/actionmailer/actionmailer-4.0.10.ebuild b/dev-ruby/actionmailer/actionmailer-4.0.10.ebuild
new file mode 100644
index 000000000000..aac8a370ec69
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.0.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.0.10.ebuild,v 1.1 2014/09/12 05:55:37 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha:0.13
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+
+ # Add json to Gemfile to fix mime-types not doing this itself.
+ sed -e '5igem "json"' -i ../Gemfile || die
+}