summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-09-25 12:53:27 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-09-25 12:53:27 +0000
commit31386ed9eab673ad8357e766b378b62879566843 (patch)
treec35cfc89bd3c0f03f4874b7dffa9f666aac843e2 /dev-ruby/IceRuby
parentremove old version (diff)
downloadgentoo-2-31386ed9eab673ad8357e766b378b62879566843.tar.gz
gentoo-2-31386ed9eab673ad8357e766b378b62879566843.tar.bz2
gentoo-2-31386ed9eab673ad8357e766b378b62879566843.zip
remove old versions
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-ruby/IceRuby')
-rw-r--r--dev-ruby/IceRuby/ChangeLog7
-rw-r--r--dev-ruby/IceRuby/IceRuby-3.2.0-r1.ebuild62
-rw-r--r--dev-ruby/IceRuby/IceRuby-3.2.0.ebuild61
-rw-r--r--dev-ruby/IceRuby/IceRuby-3.2.1.ebuild61
-rw-r--r--dev-ruby/IceRuby/files/IceRuby-3.2.0-Makefile.patch116
-rw-r--r--dev-ruby/IceRuby/files/cached_connection.patch11
-rw-r--r--dev-ruby/IceRuby/files/digest-IceRuby-3.2.03
-rw-r--r--dev-ruby/IceRuby/files/digest-IceRuby-3.2.0-r13
-rw-r--r--dev-ruby/IceRuby/files/digest-IceRuby-3.2.13
9 files changed, 6 insertions, 321 deletions
diff --git a/dev-ruby/IceRuby/ChangeLog b/dev-ruby/IceRuby/ChangeLog
index 9a80a7fd0169..91dc90fbd1b4 100644
--- a/dev-ruby/IceRuby/ChangeLog
+++ b/dev-ruby/IceRuby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/IceRuby
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/ChangeLog,v 1.8 2007/08/27 11:26:53 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/ChangeLog,v 1.9 2007/09/25 12:53:26 caleb Exp $
+
+ 25 Sep 2007; Caleb Tennis <caleb@gentoo.org>
+ -files/IceRuby-3.2.0-Makefile.patch, -files/cached_connection.patch,
+ -IceRuby-3.2.0.ebuild, -IceRuby-3.2.0-r1.ebuild, -IceRuby-3.2.1.ebuild:
+ remove old versions
*IceRuby-3.2.1-r1 (27 Aug 2007)
diff --git a/dev-ruby/IceRuby/IceRuby-3.2.0-r1.ebuild b/dev-ruby/IceRuby/IceRuby-3.2.0-r1.ebuild
deleted file mode 100644
index 2ce8b6739eb5..000000000000
--- a/dev-ruby/IceRuby/IceRuby-3.2.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/IceRuby-3.2.0-r1.ebuild,v 1.1 2007/07/24 12:06:28 caleb Exp $
-
-inherit eutils
-
-DESCRIPTION="ICE middleware C++ bindings"
-HOMEPAGE="http://www.zeroc.com/index.html"
-SRC_URI="http://www.zeroc.com/download/Ice/3.2/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="test debug"
-
-RDEPEND="=dev-cpp/Ice-3.2*
- >=dev-lang/ruby-1.8.4"
-
-DEPEND="${RDEPEND}
- test? ( >=dev-lang/python-2.4 )"
-
-src_unpack() {
-# export ICE_HOME=/usr
- unpack ${A}
- cd "${S}"
-
- epatch ${FILESDIR}/${P}-Makefile.patch
- epatch ${FILESDIR}/cached_connection.patch
-
- mkdir -p ${S}/bin
- mkdir -p ${S}/lib
-
- if use amd64; then
- sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
- || die "Failed to set lib64 directory"
- fi
-
- if ! use debug; then
- sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
- ${S}/config/Make.rules || die "Failed to remove debug"
- fi
-
- sed -i -e \
- "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
- ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
-}
-
-src_compile() {
- cd ${S}
-# export ICE_HOME=/usr
- make || die "Died during make"
-}
-
-src_install() {
-# export ICE_HOME=/usr
- make DESTDIR="${D}" install || die "Install Failed!"
-}
-
-src_test() {
-# export ICE_HOME=/usr
- make test || die "Test failed"
-}
diff --git a/dev-ruby/IceRuby/IceRuby-3.2.0.ebuild b/dev-ruby/IceRuby/IceRuby-3.2.0.ebuild
deleted file mode 100644
index 3a5c99354d41..000000000000
--- a/dev-ruby/IceRuby/IceRuby-3.2.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/IceRuby-3.2.0.ebuild,v 1.1 2007/03/13 14:04:44 caleb Exp $
-
-inherit eutils
-
-DESCRIPTION="ICE middleware C++ bindings"
-HOMEPAGE="http://www.zeroc.com/index.html"
-SRC_URI="http://www.zeroc.com/download/Ice/3.2/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="test debug"
-
-RDEPEND="=dev-cpp/Ice-3.2*
- >=dev-lang/ruby-1.8.4"
-
-DEPEND="${RDEPEND}
- test? ( >=dev-lang/python-2.4 )"
-
-src_unpack() {
-# export ICE_HOME=/usr
- unpack ${A}
- cd "${S}"
-
- epatch ${FILESDIR}/${P}-Makefile.patch
-
- mkdir -p ${S}/bin
- mkdir -p ${S}/lib
-
- if use amd64; then
- sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
- || die "Failed to set lib64 directory"
- fi
-
- if ! use debug; then
- sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
- ${S}/config/Make.rules || die "Failed to remove debug"
- fi
-
- sed -i -e \
- "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
- ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
-}
-
-src_compile() {
- cd ${S}
-# export ICE_HOME=/usr
- make || die "Died during make"
-}
-
-src_install() {
-# export ICE_HOME=/usr
- make DESTDIR="${D}" install || die "Install Failed!"
-}
-
-src_test() {
-# export ICE_HOME=/usr
- make test || die "Test failed"
-}
diff --git a/dev-ruby/IceRuby/IceRuby-3.2.1.ebuild b/dev-ruby/IceRuby/IceRuby-3.2.1.ebuild
deleted file mode 100644
index 8e7e05cc802b..000000000000
--- a/dev-ruby/IceRuby/IceRuby-3.2.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/IceRuby-3.2.1.ebuild,v 1.1 2007/08/15 15:45:54 caleb Exp $
-
-inherit eutils
-
-DESCRIPTION="ICE middleware C++ bindings"
-HOMEPAGE="http://www.zeroc.com/index.html"
-SRC_URI="http://www.zeroc.com/download/Ice/3.2/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="test debug"
-
-RDEPEND="~dev-cpp/Ice-3.2.1
- >=dev-lang/ruby-1.8.4"
-
-DEPEND="${RDEPEND}
- test? ( >=dev-lang/python-2.4 )"
-
-src_unpack() {
-# export ICE_HOME=/usr
- unpack ${A}
- cd "${S}"
-
- epatch ${FILESDIR}/${P}-Makefile.patch
-
- mkdir -p ${S}/bin
- mkdir -p ${S}/lib
-
- if use amd64; then
- sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
- || die "Failed to set lib64 directory"
- fi
-
- if ! use debug; then
- sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
- ${S}/config/Make.rules || die "Failed to remove debug"
- fi
-
- sed -i -e \
- "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
- ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
-}
-
-src_compile() {
- cd ${S}
-# export ICE_HOME=/usr
- make || die "Died during make"
-}
-
-src_install() {
-# export ICE_HOME=/usr
- make DESTDIR="${D}" install || die "Install Failed!"
-}
-
-src_test() {
-# export ICE_HOME=/usr
- make test || die "Test failed"
-}
diff --git a/dev-ruby/IceRuby/files/IceRuby-3.2.0-Makefile.patch b/dev-ruby/IceRuby/files/IceRuby-3.2.0-Makefile.patch
deleted file mode 100644
index 3093e58a78bc..000000000000
--- a/dev-ruby/IceRuby/files/IceRuby-3.2.0-Makefile.patch
+++ /dev/null
@@ -1,116 +0,0 @@
---- Makefile.orig 2007-03-13 08:29:51.000000000 -0400
-+++ Makefile 2007-03-13 08:31:16.000000000 -0400
-@@ -13,13 +13,13 @@
-
- SUBDIRS = src ruby
-
--INSTALL_SUBDIRS = $(install_libdir) $(install_rubydir)
-+INSTALL_SUBDIRS = $(install_rubylibdir) $(install_rubyarchdir)
-
- install::
- @if test ! -d $(prefix) ; \
- then \
- echo "Creating $(prefix)..." ; \
-- $(call mkdir,$(prefix)) ; \
-+ mkdir -p $(prefix) ; \
- fi
- @for subdir in $(INSTALL_SUBDIRS); \
- do \
-@@ -38,9 +38,5 @@
- ( cd $$subdir && $(MAKE) $@ ) || exit 1; \
- done
-
--install::
-- $(call installdata,ICE_LICENSE,$(prefix))
-- $(call installdata,LICENSE,$(prefix))
--
- test::
- @python $(top_srcdir)/allTests.py
---- ruby/Makefile.orig 2007-03-13 08:31:21.000000000 -0400
-+++ ruby/Makefile 2007-03-13 08:31:50.000000000 -0400
-@@ -128,8 +128,8 @@
- @echo "Installing generated code"
- @for i in $(MODULES) ; \
- do \
-- $(INSTALL_DATA) $${i}.rb $(install_rubydir) ; \
-- $(INSTALL_DATA) -r $$i $(install_rubydir) ; \
-+ $(INSTALL_DATA) $${i}.rb $(install_rubylibdir) ; \
-+ $(INSTALL_DATA) -r $$i $(install_rubylibdir) ; \
- done
-
- clean::
---- src/IceRuby/Makefile.orig 2007-03-13 08:31:58.000000000 -0400
-+++ src/IceRuby/Makefile 2007-03-13 08:35:59.000000000 -0400
-@@ -48,6 +48,6 @@
- ln -s $(SONAME) $@
-
- install:: all
-- $(call installlib,$(install_libdir),$(libdir),$(LIBFILENAME),$(SONAME),$(LIBNAME))
-+ $(call installlib,$(install_rubyarchdir),$(libdir),$(LIBFILENAME),$(SONAME),$(LIBNAME))
-
- include .depend
---- config/Make.rules.orig 2007-03-13 08:33:15.000000000 -0400
-+++ config/Make.rules 2007-03-13 08:35:04.000000000 -0400
-@@ -18,13 +18,13 @@
- # if it does not exist.
- #
-
--prefix = /opt/IceRuby-$(VERSION)
-+prefix = $(DESTDIR)/usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with optimization.
-@@ -51,8 +51,10 @@
- RUBY = ruby
- endif
-
--RUBY_INCLUDE_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(archdir)")')
--RUBY_LIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(libdir)")')
-+RUBY_ARCH_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(archdir)")')
-+RUBY_LIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(rubylibdir)")')
-+RUBY_SITEARCH_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(sitearchdir)")')
-+RUBY_SITELIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(sitelibdir)")')
-
- RUBY_SHARED = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::MAKEFILE_CONFIG["ENABLE_SHARED"]')
-
-@@ -62,7 +64,7 @@
- RUBY_LIB = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("-l$$(RUBY_SO_NAME)-static")')
- endif
-
--RUBY_FLAGS = -I$(RUBY_INCLUDE_DIR)
-+RUBY_FLAGS = -I$(RUBY_ARCH_DIR)
- RUBY_LIBS = -L$(RUBY_LIB_DIR) $(RUBY_LIB)
-
- ifneq ($(ICE_HOME),)
-@@ -100,7 +102,8 @@
- endif
-
- install_bindir = $(prefix)/bin
--install_rubydir = $(prefix)/ruby
-+install_rubylibdir = $(DESTDIR)/$(RUBY_SITELIB_DIR)
-+install_rubyarchdir = $(DESTDIR)/$(RUBY_SITEARCH_DIR)
-
- INSTALL = cp -fp
- INSTALL_PROGRAM = ${INSTALL}
---- config/Make.rules.orig 2007-03-13 09:51:34.000000000 -0400
-+++ config/Make.rules 2007-03-13 09:51:59.000000000 -0400
-@@ -93,11 +93,7 @@
- libdir = $(top_srcdir)/ruby
- rubydir = $(top_srcdir)/ruby
-
--ifneq ($(ICE_HOME),)
-- slicedir = $(ICE_HOME)/slice
--else
-- slicedir = /usr/share/Ice-$(VERSION)/slice
--endif
-+slicedir = /usr/share/Ice/slice
-
- install_bindir = $(prefix)/bin
- install_rubydir = $(prefix)/ruby
diff --git a/dev-ruby/IceRuby/files/cached_connection.patch b/dev-ruby/IceRuby/files/cached_connection.patch
deleted file mode 100644
index 2acd2f8f3868..000000000000
--- a/dev-ruby/IceRuby/files/cached_connection.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/IceRuby/Proxy.cpp.orig 2007-07-24 08:02:19.000000000 -0400
-+++ src/IceRuby/Proxy.cpp 2007-07-24 08:02:35.000000000 -0400
-@@ -990,7 +990,7 @@
- {
- Ice::ObjectPrx p = getProxy(self);
- Ice::ConnectionPtr conn = p->ice_getCachedConnection();
-- if(!conn)
-+ if(conn)
- {
- return createConnection(conn);
- }
diff --git a/dev-ruby/IceRuby/files/digest-IceRuby-3.2.0 b/dev-ruby/IceRuby/files/digest-IceRuby-3.2.0
deleted file mode 100644
index 657acb05e89f..000000000000
--- a/dev-ruby/IceRuby/files/digest-IceRuby-3.2.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 12acd1d20ea9ca0350651c1094a673e2 IceRuby-3.2.0.tar.gz 95823
-RMD160 56c8464918673820993a4c364a16069bf5420cbf IceRuby-3.2.0.tar.gz 95823
-SHA256 b3d89a8811f163dc6725bde1b56487675e6549d203129abad4abb6a6167ce87f IceRuby-3.2.0.tar.gz 95823
diff --git a/dev-ruby/IceRuby/files/digest-IceRuby-3.2.0-r1 b/dev-ruby/IceRuby/files/digest-IceRuby-3.2.0-r1
deleted file mode 100644
index 657acb05e89f..000000000000
--- a/dev-ruby/IceRuby/files/digest-IceRuby-3.2.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 12acd1d20ea9ca0350651c1094a673e2 IceRuby-3.2.0.tar.gz 95823
-RMD160 56c8464918673820993a4c364a16069bf5420cbf IceRuby-3.2.0.tar.gz 95823
-SHA256 b3d89a8811f163dc6725bde1b56487675e6549d203129abad4abb6a6167ce87f IceRuby-3.2.0.tar.gz 95823
diff --git a/dev-ruby/IceRuby/files/digest-IceRuby-3.2.1 b/dev-ruby/IceRuby/files/digest-IceRuby-3.2.1
deleted file mode 100644
index 81a0e82c619d..000000000000
--- a/dev-ruby/IceRuby/files/digest-IceRuby-3.2.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 17c61065ab67c232283d8710302379d3 IceRuby-3.2.1.tar.gz 98496
-RMD160 7c852a275fe5d37bee2654889ed268022e7f1cd7 IceRuby-3.2.1.tar.gz 98496
-SHA256 319ccbf5945a9f213695c67a4bdead8605c25c0c6de926e272c4a21619ae30bf IceRuby-3.2.1.tar.gz 98496