summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-11 09:52:36 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-11 09:52:36 +0000
commitc16a0a88c30c8de6e5435155b37b1f23f6ae92d9 (patch)
tree60f2b570235d4f69707a394780de0dfceb08fbf8 /dev-python
parentthe manifests (diff)
downloadgentoo-2-c16a0a88c30c8de6e5435155b37b1f23f6ae92d9.tar.gz
gentoo-2-c16a0a88c30c8de6e5435155b37b1f23f6ae92d9.tar.bz2
gentoo-2-c16a0a88c30c8de6e5435155b37b1f23f6ae92d9.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/miniupnpc/ChangeLog9
-rw-r--r--dev-python/miniupnpc/miniupnpc-1.8.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/miniupnpc/ChangeLog b/dev-python/miniupnpc/ChangeLog
index be1702485eb9..a29bfe2166c4 100644
--- a/dev-python/miniupnpc/ChangeLog
+++ b/dev-python/miniupnpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/miniupnpc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/miniupnpc/ChangeLog,v 1.8 2012/12/17 19:58:57 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/miniupnpc/ChangeLog,v 1.9 2013/02/11 09:52:36 mgorny Exp $
+
+*miniupnpc-1.8 (11 Feb 2013)
+
+ 11 Feb 2013; Michał Górny <mgorny@gentoo.org> +miniupnpc-1.8.ebuild:
+ Version bump.
17 Dec 2012; Michał Górny <mgorny@gentoo.org> miniupnpc-1.7-r1.ebuild:
Bump to EAPI=5 to make Paludis happy, bug #447524.
diff --git a/dev-python/miniupnpc/miniupnpc-1.8.ebuild b/dev-python/miniupnpc/miniupnpc-1.8.ebuild
new file mode 100644
index 000000000000..b00231b64ba5
--- /dev/null
+++ b/dev-python/miniupnpc/miniupnpc-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/miniupnpc/miniupnpc-1.8.ebuild,v 1.1 2013/02/11 09:52:36 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_6 python2_7 pypy1_9)
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for UPnP client library"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/miniupnpc-${PV}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/0001-Link-Python-module-against-the-shared-library.patch
+)
+
+# DOCS are installed by net-libs/miniupnpc.
+DOCS=()