summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-24 16:27:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-24 16:27:42 +0000
commitb2508a44bcfce18de5d9c20bc83fbe5e9e86c68d (patch)
tree2e158069f6c90da430f73694dc917862b829b31f /dev-python
parentAdd sys-kernel/hardened-sources-2.6.27-r5 (diff)
downloadgentoo-2-b2508a44bcfce18de5d9c20bc83fbe5e9e86c68d.tar.gz
gentoo-2-b2508a44bcfce18de5d9c20bc83fbe5e9e86c68d.tar.bz2
gentoo-2-b2508a44bcfce18de5d9c20bc83fbe5e9e86c68d.zip
Bump to 1.8.2, fixes #255360
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycairo/ChangeLog9
-rw-r--r--dev-python/pycairo/pycairo-1.8.2.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index e7971de6f42f..d1f8a520e2a5 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycairo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.60 2008/11/10 11:33:19 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.61 2009/01/24 16:27:42 patrick Exp $
+
+*pycairo-1.8.2 (24 Jan 2009)
+
+ 24 Jan 2009; Patrick Lauer <patrick@gentoo.org> +pycairo-1.8.2.ebuild:
+ Bump to 1.8.2, fixes #255360
10 Nov 2008; Raúl Porcel <armin76@gentoo.org> pycairo-1.4.12.ebuild:
arm/sh stable
diff --git a/dev-python/pycairo/pycairo-1.8.2.ebuild b/dev-python/pycairo/pycairo-1.8.2.ebuild
new file mode 100644
index 000000000000..7504affce9fc
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.8.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.2.ebuild,v 1.1 2009/01/24 16:27:42 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/pycairo/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=x11-libs/cairo-1.4.12"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PYTHON_MODNAME="cairo"
+DOCS="AUTHORS doc/*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't run py-compile
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ rm "${D}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+}
+
+src_test() {
+ cd test
+ PYTHONPATH="$(ls -d ${S}/build/lib.*)" "${python}" test.py || die "tests failed"
+}