summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 21:10:25 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 21:10:25 +0000
commit948e5b71de05080003d03d87325bfd267c61bd30 (patch)
tree15455c0964132808bda87b98589551bb1dcbc71f /dev-python
parentadd inherit eutils (diff)
downloadgentoo-2-948e5b71de05080003d03d87325bfd267c61bd30.tar.gz
gentoo-2-948e5b71de05080003d03d87325bfd267c61bd30.tar.bz2
gentoo-2-948e5b71de05080003d03d87325bfd267c61bd30.zip
add inherit eutils
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild15
-rw-r--r--dev-python/PyQt/PyQt-3.10.ebuild9
-rw-r--r--dev-python/PyQt/PyQt-3.8.1.ebuild12
-rw-r--r--dev-python/bsddb3/bsddb3-4.1.3.ebuild10
4 files changed, 22 insertions, 24 deletions
diff --git a/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild b/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild
index b3c92b192b3d..d2d6cacf0885 100644
--- a/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild
+++ b/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild
@@ -1,22 +1,21 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild,v 1.4 2003/10/30 09:49:10 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild,v 1.5 2004/04/25 21:09:06 vapier Exp $
PYTHON_SLOT_VERSION="2.1"
-inherit distutils
+inherit distutils eutils
P_NEW="${PN%-py21}-${PV}"
S="${WORKDIR}/${P_NEW}"
-IUSE="tcltk"
-
DESCRIPTION="Python Imaging Library (PIL)."
HOMEPAGE="http://www.pythonware.com/products/pil/index.htm"
SRC_URI="http://www.effbot.org/downloads/${P_NEW}.tar.gz"
+LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86 ~sparc ~alpha ~ppc"
-LICENSE="as-is"
+IUSE="tcltk"
DEPEND=">=media-libs/jpeg-6a
>=sys-libs/zlib-0.95
@@ -45,8 +44,7 @@ src_compile() {
#CFLAGS="$(CFLAGS) -DUSE_COMPOSITELESS_PHOTO_PUT_BLOCK" distutils_src_compile
}
-src_install ()
-{
+src_install() {
local mydoc="CHANGES* CONTENTS"
distutils_src_install
distutils_python_version
@@ -57,4 +55,3 @@ src_install ()
doins libImaging/ImPlatform.h
doins libImaging/ImConfig.h
}
-
diff --git a/dev-python/PyQt/PyQt-3.10.ebuild b/dev-python/PyQt/PyQt-3.10.ebuild
index c48fcc5949fe..630f28f401dc 100644
--- a/dev-python/PyQt/PyQt-3.10.ebuild
+++ b/dev-python/PyQt/PyQt-3.10.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.10.ebuild,v 1.3 2004/03/14 21:09:52 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.10.ebuild,v 1.4 2004/04/25 21:09:26 vapier Exp $
-inherit distutils
+inherit distutils eutils
-IUSE=""
MY_P="PyQt-x11-gpl-${PV}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE=""
PV_MAJOR=${PV/.*/}
PV_MINOR=${PV#${PV_MAJOR}.}
PV_MINOR=${PV_MINOR/.*}
diff --git a/dev-python/PyQt/PyQt-3.8.1.ebuild b/dev-python/PyQt/PyQt-3.8.1.ebuild
index aafb2d2cfb3a..687546661cd5 100644
--- a/dev-python/PyQt/PyQt-3.8.1.ebuild
+++ b/dev-python/PyQt/PyQt-3.8.1.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.6 2004/03/03 21:37:46 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.7 2004/04/25 21:10:05 vapier Exp $
-inherit distutils
-
-IUSE=""
+inherit distutils eutils
S="${WORKDIR}/PyQt-x11-gpl-${PV}"
DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
SRC_URI="mirror://gentoo/PyQt-x11-gpl-${PV}.tar.gz"
#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc sparc ~alpha"
+IUSE=""
PV_MAJOR=${PV/.*/}
PV_MINOR=${PV#${PV_MAJOR}.}
diff --git a/dev-python/bsddb3/bsddb3-4.1.3.ebuild b/dev-python/bsddb3/bsddb3-4.1.3.ebuild
index 8245008aa134..fd81bb494e0b 100644
--- a/dev-python/bsddb3/bsddb3-4.1.3.ebuild
+++ b/dev-python/bsddb3/bsddb3-4.1.3.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.1.3.ebuild,v 1.8 2004/03/30 08:00:16 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.1.3.ebuild,v 1.9 2004/04/25 21:10:25 vapier Exp $
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Python bindings for BerkeleyDB"
HOMEPAGE="http://pybsddb.sourceforge.net/"
SRC_URI="mirror://sourceforge/pybsddb/${P}.tar.gz"
-LICENSE="BSD"
+LICENSE="BSD"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~amd64"
IUSE=""
@@ -20,7 +20,8 @@ DOCS="README.txt TODO.txt"
src_unpack() {
unpack ${A}
- cd ${S}; epatch ${FILESDIR}/${P}-db4.0.patch
+ cd ${S}
+ epatch ${FILESDIR}/${P}-db4.0.patch
}
src_compile() {
@@ -31,4 +32,3 @@ src_install() {
distutils_src_install "--berkeley-db=/usr"
dohtml docs/*
}
-