summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2015-05-06 21:31:23 +0000
committerPatrick McLean <chutzpah@gentoo.org>2015-05-06 21:31:23 +0000
commit69ffe3a859fec8c762e97aef9463846c28d1d12c (patch)
tree426a769b82dab2efdd2d5b01c49e0ba24e35e419 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-69ffe3a859fec8c762e97aef9463846c28d1d12c.tar.gz
gentoo-2-69ffe3a859fec8c762e97aef9463846c28d1d12c.tar.bz2
gentoo-2-69ffe3a859fec8c762e97aef9463846c28d1d12c.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/raet/ChangeLog10
-rw-r--r--dev-python/raet/raet-0.6.1.ebuild30
2 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/raet/ChangeLog b/dev-python/raet/ChangeLog
index c4491da9300a..4ed0d55ccea8 100644
--- a/dev-python/raet/ChangeLog
+++ b/dev-python/raet/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-python/raet
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/raet/ChangeLog,v 1.1 2014/11/13 00:55:17 chutzpah Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/raet/ChangeLog,v 1.2 2015/05/06 21:31:23 chutzpah Exp $
+
+*raet-0.6.1 (06 May 2015)
+
+ 06 May 2015; Patrick McLean <chutzpah@gentoo.org> +raet-0.6.1.ebuild:
+ Version bump.
*raet-0.3.8 (13 Nov 2014)
13 Nov 2014; Patrick McLean <chutzpah@gentoo.org> +raet-0.3.8.ebuild,
+metadata.xml:
New package, Reliable Asynchronous Event Transport Protocol
-
diff --git a/dev-python/raet/raet-0.6.1.ebuild b/dev-python/raet/raet-0.6.1.ebuild
new file mode 100644
index 000000000000..f0a0a6beb306
--- /dev/null
+++ b/dev-python/raet/raet-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/raet/raet-0.6.1.ebuild,v 1.1 2015/05/06 21:31:23 chutzpah Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Reliable Asynchronous Event Transport Protocol"
+HOMEPAGE="https://github.com/saltstack/raet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/libnacl-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ioflo-1.2.1[${PYTHON_USEDEP}]
+ python_targets_python2_7? ( >=dev-python/enum34-1.0.4[$(python_gen_usedep 'python2*')] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib
+ ${EPYTHON} ${PN}/test/__init__.py || die "tests failed for ${EPYTHON}"
+ popd
+}