summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-02 22:03:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-02 22:03:11 +0000
commit4aeda9159c188d8538ec9c7cd95dbe5fba241cf7 (patch)
tree685a0318e9670eedc6cc894c6a45aacd0bdaf7de /dev-python
parentAdd a patch to fix kate build on big endian hosts, by Mounir Lamouri (volkmar... (diff)
downloadgentoo-2-4aeda9159c188d8538ec9c7cd95dbe5fba241cf7.tar.gz
gentoo-2-4aeda9159c188d8538ec9c7cd95dbe5fba241cf7.tar.bz2
gentoo-2-4aeda9159c188d8538ec9c7cd95dbe5fba241cf7.zip
Add new revision to ensure that dev-python/sip is installed by default for Python 2 and Python 3. Fix compatibility with Python 3.
(Portage version: 14475-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog9
-rw-r--r--dev-python/sip/files/sip-4.8.2-python-3.patch11
-rw-r--r--dev-python/sip/sip-4.8.2-r1.ebuild74
3 files changed, 93 insertions, 1 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index c5969b8c6f99..f8e8aa333318 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.143 2009/09/27 18:21:03 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.144 2009/10/02 22:03:11 arfrever Exp $
+
+*sip-4.8.2-r1 (02 Oct 2009)
+
+ 02 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sip-4.8.2-r1.ebuild, +files/sip-4.8.2-python-3.patch:
+ Add new revision to ensure that dev-python/sip is installed by default for
+ Python 2 and Python 3. Fix compatibility with Python 3.
27 Sep 2009; nixnut <nixnut@gentoo.org> sip-4.8.2.ebuild:
ppc stable #284707
diff --git a/dev-python/sip/files/sip-4.8.2-python-3.patch b/dev-python/sip/files/sip-4.8.2-python-3.patch
new file mode 100644
index 000000000000..344026641f69
--- /dev/null
+++ b/dev-python/sip/files/sip-4.8.2-python-3.patch
@@ -0,0 +1,11 @@
+--- sipdistutils.py
++++ sipdistutils.py
+@@ -29,7 +29,7 @@
+ out.append(os.path.join(self.build_temp, o))
+ return out
+
+- raise RuntimeError, "cannot parse SIP-generated '%s'" % sbf
++ raise RuntimeError("cannot parse SIP-generated '%s'" % sbf)
+
+ def _find_sip(self):
+ import sipconfig
diff --git a/dev-python/sip/sip-4.8.2-r1.ebuild b/dev-python/sip/sip-4.8.2-r1.ebuild
new file mode 100644
index 000000000000..e2f4dd1181ac
--- /dev/null
+++ b/dev-python/sip/sip-4.8.2-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.8.2-r1.ebuild,v 1.1 2009/10/02 22:03:11 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python toolchain-funcs
+
+MY_P=${P/_pre/-snapshot-}
+
+DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
+
+LICENSE="sip"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+# Ensure that dev-python/sip is installed by default for Python 2 and Python 3.
+RDEPEND="=dev-lang/python-2*
+ =dev-lang/python-3*"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-3.patch"
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf="$(PYTHON) configure.py
+ --bindir=/usr/bin
+ --destdir=$(python_get_sitedir)
+ --incdir=$(python_get_includedir)
+ --sipdir=/usr/share/sip
+ $(use debug && echo '--debug')
+ CC=$(tc-getCC) CXX=$(tc-getCXX)
+ LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
+ CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
+ LFLAGS='${LDFLAGS}'
+ STRIP=true"
+ echo ${myconf}
+ eval ${myconf}
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_install() {
+ python_need_rebuild
+
+ python_execute_function -d -s
+
+ dodoc ChangeLog NEWS || die
+
+ if use doc; then
+ dohtml -r doc/html/* || die
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize sipconfig.py sipdistutils.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}