summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-23 08:24:02 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-23 08:24:02 +0000
commit2700e89319e31dd670ce5b71fcad829f2faa9ef0 (patch)
tree591cf00f988618c4d6e3071d75e58d460ceb8688 /dev-python
parentVersion Bump (diff)
downloadgentoo-2-2700e89319e31dd670ce5b71fcad829f2faa9ef0.tar.gz
gentoo-2-2700e89319e31dd670ce5b71fcad829f2faa9ef0.tar.bz2
gentoo-2-2700e89319e31dd670ce5b71fcad829f2faa9ef0.zip
Version Bump
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-7.0.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index f1483f457591..1650b63a7f34 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.63 2015/05/22 11:34:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.64 2015/05/23 08:24:02 jlec Exp $
+
+*pip-7.0.1 (23 May 2015)
+
+ 23 May 2015; Justin Lecher <jlec@gentoo.org> +pip-7.0.1.ebuild:
+ Version Bump
*pip-7.0.0 (22 May 2015)
diff --git a/dev-python/pip/pip-7.0.1.ebuild b/dev-python/pip/pip-7.0.1.ebuild
new file mode 100644
index 000000000000..66e29caf3e93
--- /dev/null
+++ b/dev-python/pip/pip-7.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-7.0.1.ebuild,v 1.1 2015/05/23 08:24:02 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch )
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ ${EPYTHON} pip/__init__.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ ${EPYTHON} pip/__init__.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}