summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-08 01:20:12 +0000
committerIan Delaney <idella4@gentoo.org>2015-08-08 01:20:12 +0000
commit0ac6b190a78b4001d74dc575375827a2151056b7 (patch)
treea33636c9c871b3471c57f215b1b6c848c8eeeef3 /dev-python
parentdev-java/javacup: Break circular dependency (diff)
downloadgentoo-2-0ac6b190a78b4001d74dc575375827a2151056b7.tar.gz
gentoo-2-0ac6b190a78b4001d74dc575375827a2151056b7.tar.bz2
gentoo-2-0ac6b190a78b4001d74dc575375827a2151056b7.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oauthlib/ChangeLog7
-rw-r--r--dev-python/oauthlib/oauthlib-1.0.1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/oauthlib/ChangeLog b/dev-python/oauthlib/ChangeLog
index 9cbb697c7070..f05b8e94fc36 100644
--- a/dev-python/oauthlib/ChangeLog
+++ b/dev-python/oauthlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/oauthlib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/ChangeLog,v 1.42 2015/06/07 14:26:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/ChangeLog,v 1.43 2015/08/08 01:20:12 idella4 Exp $
+
+*oauthlib-1.0.1 (08 Aug 2015)
+
+ 08 Aug 2015; Ian Delaney <idella4@gentoo.org> +oauthlib-1.0.1.ebuild:
+ bump
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/oauthlib/oauthlib-1.0.1.ebuild b/dev-python/oauthlib/oauthlib-1.0.1.ebuild
new file mode 100644
index 000000000000..d13d914bbdce
--- /dev/null
+++ b/dev-python/oauthlib/oauthlib-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/oauthlib-1.0.1.ebuild,v 1.1 2015/08/08 01:20:12 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
+HOMEPAGE="https://github.com/idan/oauthlib http://pypi.python.org/pypi/oauthlib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# optional extras hard set as RDEPs. See setup.py
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' python2_7) )
+ "
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}