summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-04-07 18:30:59 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-04-07 18:30:59 +0000
commit0a822ff4b721714d43ee678ebf4020c9d76a7c1c (patch)
treeb03f80c74515f58b5db71f597f6000ddf3311e0c /dev-python
parentVersion bump (diff)
downloadgentoo-2-0a822ff4b721714d43ee678ebf4020c9d76a7c1c.tar.gz
gentoo-2-0a822ff4b721714d43ee678ebf4020c9d76a7c1c.tar.bz2
gentoo-2-0a822ff4b721714d43ee678ebf4020c9d76a7c1c.zip
Fixed bug #204877 ( thanks to Davide Pesavento <davidepesa@gmail.com> )
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/ChangeLog8
-rw-r--r--dev-python/PyQt4/PyQt4-4.4.4-r3.ebuild63
-rw-r--r--dev-python/PyQt4/files/configure.py.patch28
3 files changed, 98 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 52aca91bcbf5..6f1ef795c96c 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.52 2009/03/27 23:03:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.53 2009/04/07 18:30:59 hwoarang Exp $
+
+*PyQt4-4.4.4-r3 (07 Apr 2009)
+
+ 07 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
+ +files/configure.py.patch, +PyQt4-4.4.4-r3.ebuild:
+ Fixed bug #204877 ( thanks to Davide Pesavento <davidepesa@gmail.com> )
27 Mar 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r2.ebuild:
Stable for HPPA (bug #261652).
diff --git a/dev-python/PyQt4/PyQt4-4.4.4-r3.ebuild b/dev-python/PyQt4/PyQt4-4.4.4-r3.ebuild
new file mode 100644
index 000000000000..86e0ca0d8370
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.4.4-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4.4-r3.ebuild,v 1.1 2009/04/07 18:30:59 hwoarang Exp $
+
+EAPI="2"
+
+inherit distutils qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+
+DESCRIPTION="A set of Python bindings for the Qt toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt4/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus debug doc examples opengl qt3support svg webkit X"
+
+RDEPEND=">=dev-python/sip-4.7.8
+ >=x11-libs/qt-core-4.4.2:4
+ dbus? ( dev-python/dbus-python
+ >=x11-libs/qt-dbus-4.4.2:4 )
+ opengl? ( >=x11-libs/qt-opengl-4.4.2:4 )
+ svg? ( >=x11-libs/qt-svg-4.4.2:4 )
+ qt3support? ( >=x11-libs/qt-qt3support-4.4.2:4 )
+ webkit? ( >=x11-libs/qt-webkit-4.4.2:4 )
+ X? ( >=x11-libs/qt-gui-4.4.2:4 )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/configure.py.patch"
+)
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" "${S}"/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" "${S}"/configure.py
+}
+
+src_configure() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/configure.py.patch b/dev-python/PyQt4/files/configure.py.patch
new file mode 100644
index 000000000000..11160b99be87
--- /dev/null
+++ b/dev-python/PyQt4/files/configure.py.patch
@@ -0,0 +1,28 @@
+diff -Naur PyQt-x11-gpl-4.4.4~orig/configure.py PyQt-x11-gpl-4.4.4/configure.py
+--- PyQt-x11-gpl-4.4.4~orig/configure.py 2009-03-26 01:01:43.000000000 +0100
++++ PyQt-x11-gpl-4.4.4/configure.py 2009-03-26 01:09:50.000000000 +0100
+@@ -666,6 +666,7 @@
+ install_dir=pydbusmoddir,
+ qt=["QtCore"],
+ debug=opts.debug,
++ strip=0,
+ universal=sipcfg.universal
+ )
+
+@@ -1350,6 +1351,7 @@
+ warnings=1,
+ static=opts.static,
+ debug=opts.debug,
++ strip=0,
+ universal=sipcfg.universal
+ )
+
+@@ -1510,7 +1512,7 @@
+ # The Qt binary installer has macx-xcode as the default.
+ args = "-spec macx-g++ " + args
+
+- return args
++ return " QMAKE_STRIP= " + args
+
+
+ def get_qt_configuration():