summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-01-03 23:50:40 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-01-03 23:50:40 +0000
commit007a08dfc172afa58ea5518a3d54cff21222bde5 (patch)
treefb8c06afa7aeb61553df53a69e60097f4b252b22 /dev-python
parentallow building without ocamlopt (diff)
downloadgentoo-2-007a08dfc172afa58ea5518a3d54cff21222bde5.tar.gz
gentoo-2-007a08dfc172afa58ea5518a3d54cff21222bde5.tar.bz2
gentoo-2-007a08dfc172afa58ea5518a3d54cff21222bde5.zip
bump to 2.14.1
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/ChangeLog10
-rw-r--r--dev-python/pygobject/files/digest-pygobject-2.14.13
-rw-r--r--dev-python/pygobject/pygobject-2.14.1.ebuild80
3 files changed, 91 insertions, 2 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 200e90345900..d12b13539723 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygobject
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.30 2007/12/27 18:04:50 eva Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.31 2008/01/03 23:50:39 eva Exp $
+
+*pygobject-2.14.1 (03 Jan 2008)
+
+ 03 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +pygobject-2.14.1.ebuild:
+ bump to 2.14.1
*pygobject-2.14.0-r1 (27 Dec 2007)
diff --git a/dev-python/pygobject/files/digest-pygobject-2.14.1 b/dev-python/pygobject/files/digest-pygobject-2.14.1
new file mode 100644
index 000000000000..9f0587b24b63
--- /dev/null
+++ b/dev-python/pygobject/files/digest-pygobject-2.14.1
@@ -0,0 +1,3 @@
+MD5 d403998bc0c5034b21bd75ae7b704f4a pygobject-2.14.1.tar.bz2 363032
+RMD160 086d96f059a7317f828e9b8265a9bf62420c3c1b pygobject-2.14.1.tar.bz2 363032
+SHA256 950c8fc56f688672e27ffcebcb4cffdba99688a5c8e61655705e61c9b68d2d65 pygobject-2.14.1.tar.bz2 363032
diff --git a/dev-python/pygobject/pygobject-2.14.1.ebuild b/dev-python/pygobject/pygobject-2.14.1.ebuild
new file mode 100644
index 000000000000..b13c6a4a4538
--- /dev/null
+++ b/dev-python/pygobject/pygobject-2.14.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.1.ebuild,v 1.1 2008/01/03 23:50:39 eva Exp $
+
+WANT_AUTOMAKE=1.9.6
+inherit gnome2 python autotools
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+# glib higher dep than in configure.in comes from a runtime version check and ensures that
+# timeout_add_seconds is available for any packages that depend on pygobject and use it
+# python high dep for a fixed python-config, as aclocal.m4/configure in the tarball requires it to function properly
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-libs/glib-2.13.5
+ !<dev-python/pygtk-2.9"
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ # activate libffi when bug #199850 is solved
+ G2CONF="${G2CONF} $(use_enable doc docs) --without-libffi"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix bug #147285 - Robin H. Johnson <robbat2@gentoo.org>
+ # this is caused by upstream's automake-1.8 lacking some Gentoo-specific
+ # patches (for tmpfs amongst other things). Upstreams hit by this should
+ # move to newer automake versions ideally.
+ # eautomake
+
+ # fix bug #198875 and bug #194632
+ epatch "${FILESDIR}/${PN}-2.14.0-libffi-magic.patch"
+
+ # uncomment above eautomake when eautoreconf isn't needed anymore
+ cp aclocal.m4 old.m4
+ AT_M4DIR="." eautoreconf
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+
+ python_version
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}