summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-10-21 06:41:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-10-21 06:41:13 +0000
commitf5973d8781b5300f26382342b45cf00f6d7e94f6 (patch)
tree5c39d08001c1e6a214f46e1e4b32c31bdd700af3 /dev-python/xmltodict
parentAlso mask relevant asset pipeline packages for Rails 3.1, fixing bug 488824 a... (diff)
downloadgentoo-2-f5973d8781b5300f26382342b45cf00f6d7e94f6.tar.gz
gentoo-2-f5973d8781b5300f26382342b45cf00f6d7e94f6.tar.bz2
gentoo-2-f5973d8781b5300f26382342b45cf00f6d7e94f6.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/xmltodict')
-rw-r--r--dev-python/xmltodict/ChangeLog8
-rw-r--r--dev-python/xmltodict/xmltodict-0.8.1.ebuild22
2 files changed, 28 insertions, 2 deletions
diff --git a/dev-python/xmltodict/ChangeLog b/dev-python/xmltodict/ChangeLog
index 2d6d1d951969..de6cf79bdb16 100644
--- a/dev-python/xmltodict/ChangeLog
+++ b/dev-python/xmltodict/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/xmltodict
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/ChangeLog,v 1.2 2013/10/04 03:19:27 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/ChangeLog,v 1.3 2013/10/21 06:41:13 patrick Exp $
+
+*xmltodict-0.8.1 (21 Oct 2013)
+
+ 21 Oct 2013; Patrick Lauer <patrick@gentoo.org> +xmltodict-0.8.1.ebuild:
+ Bump
04 Oct 2013; Tim Harder <radhermit@gentoo.org> xmltodict-0.7.0.ebuild,
metadata.xml:
@@ -11,4 +16,3 @@
04 Oct 2013; Tim Harder <radhermit@gentoo.org> +xmltodict-0.7.0.ebuild,
+metadata.xml:
Initial import.
-
diff --git a/dev-python/xmltodict/xmltodict-0.8.1.ebuild b/dev-python/xmltodict/xmltodict-0.8.1.ebuild
new file mode 100644
index 000000000000..7f632fcbb78a
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.8.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/xmltodict-0.8.1.ebuild,v 1.1 2013/10/21 06:41:13 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.python.org/pypi/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}