summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-01-06 21:25:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-01-06 21:25:12 +0000
commit711a11acd54011068fce9c28b739e20e08ab2912 (patch)
tree8f4cf82e0e315f1662260a53ea892fe042bdf4af /dev-python/wxpython/wxpython-2.8.12.1.ebuild
parentFix dependencies. Restrict PyPy ABIs. Add doc USE flag. Call distutils_src_pr... (diff)
downloadgentoo-2-711a11acd54011068fce9c28b739e20e08ab2912.tar.gz
gentoo-2-711a11acd54011068fce9c28b739e20e08ab2912.tar.bz2
gentoo-2-711a11acd54011068fce9c28b739e20e08ab2912.zip
Don't inherit unused eclass. Properly set local variables. Patch by Arfrever.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython/wxpython-2.8.12.1.ebuild')
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/wxpython/wxpython-2.8.12.1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
index e9505c3eadbc..929a022501b5 100644
--- a/dev-python/wxpython/wxpython-2.8.12.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.1 2011/12/09 05:04:54 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.2 2012/01/06 21:25:12 hwoarang Exp $
EAPI="4"
PYTHON_DEPEND="2"
WX_GTK_VER="2.8"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit alternatives eutils fdo-mime flag-o-matic multilib python wxwidgets
+inherit alternatives eutils fdo-mime flag-o-matic python wxwidgets
MY_P="${P/wxpython-/wxPython-src-}"
@@ -38,8 +39,6 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
S="${WORKDIR}/${MY_P}/wxPython"
DOC_S="${WORKDIR}/wxPython-${PV}"
@@ -84,7 +83,7 @@ src_compile() {
}
src_install() {
- local docdir mypyconf
+ local docdir file mypyconf
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \