summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-06-09 07:56:53 +0000
committerJustin Lecher <jlec@gentoo.org>2014-06-09 07:56:53 +0000
commit9d3336cf98fd35c41cc6ff74bcfa788a2ce46ec1 (patch)
treebd3c102a67150042268d24131fc2a1820c557b36 /dev-python/wsgiintercept
parentBump (diff)
downloadgentoo-2-9d3336cf98fd35c41cc6ff74bcfa788a2ce46ec1.tar.gz
gentoo-2-9d3336cf98fd35c41cc6ff74bcfa788a2ce46ec1.tar.bz2
gentoo-2-9d3336cf98fd35c41cc6ff74bcfa788a2ce46ec1.zip
dev-python/wsgiintercept: Version Bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/wsgiintercept')
-rw-r--r--dev-python/wsgiintercept/ChangeLog7
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/wsgiintercept/ChangeLog b/dev-python/wsgiintercept/ChangeLog
index b5553a1876ef..7132d7d9f4c6 100644
--- a/dev-python/wsgiintercept/ChangeLog
+++ b/dev-python/wsgiintercept/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wsgiintercept
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.6 2014/05/24 09:57:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.7 2014/06/09 07:56:53 jlec Exp $
+
+*wsgiintercept-0.6.4 (09 Jun 2014)
+
+ 09 Jun 2014; Justin Lecher <jlec@gentoo.org> +wsgiintercept-0.6.4.ebuild:
+ Version Bump
*wsgiintercept-0.6.3 (24 May 2014)
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild
new file mode 100644
index 000000000000..bf2ec47c3914
--- /dev/null
+++ b/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild,v 1.1 2014/06/09 07:56:53 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="wsgi_intercept"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI application in place of a real URI for testing"
+HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://github.com/cdent/python3-wsgi-intercept"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+_PATCHES=( "${FILESDIR}/0.6.0-fix-tests.patch" )
+
+python_test() {
+ py.test || die
+}