summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-20 01:19:38 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-20 01:19:38 +0000
commitcd7406310a9c440b519d18eb5ef122210b5df065 (patch)
tree741a6a31c3fcdda5a279aecf5f19f83a7a96964b /dev-python/webtest
parentVersion bump for gnome-3.4, adds support for lists in --forms. (diff)
downloadgentoo-2-cd7406310a9c440b519d18eb5ef122210b5df065.tar.gz
gentoo-2-cd7406310a9c440b519d18eb5ef122210b5df065.tar.bz2
gentoo-2-cd7406310a9c440b519d18eb5ef122210b5df065.zip
Version bump for #414475. Enable python 3. Thanks to Ian Delaney for digging into the test suite.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog9
-rw-r--r--dev-python/webtest/files/webtest-1.3.4-index_fixt.patch13
-rw-r--r--dev-python/webtest/webtest-1.3.4.ebuild60
3 files changed, 81 insertions, 1 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index e73521303e37..9d7855a4cfaa 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.33 2012/04/16 02:24:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.34 2012/05/20 01:19:38 floppym Exp $
+
+*webtest-1.3.4 (20 May 2012)
+
+ 20 May 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/webtest-1.3.4-index_fixt.patch, +webtest-1.3.4.ebuild:
+ Version bump for #414475. Enable python 3. Thanks to Ian Delaney for digging
+ into the test suite.
16 Apr 2012; Jeroen Roovers <jer@gentoo.org> webtest-1.3.ebuild:
Marked ~hppa (bug #411761).
diff --git a/dev-python/webtest/files/webtest-1.3.4-index_fixt.patch b/dev-python/webtest/files/webtest-1.3.4-index_fixt.patch
new file mode 100644
index 000000000000..5cb75c7ea138
--- /dev/null
+++ b/dev-python/webtest/files/webtest-1.3.4-index_fixt.patch
@@ -0,0 +1,13 @@
+--- /dev/null 2012-05-03 18:34:53.288000099 +0800
++++ docs/index_fixt.py 2012-05-07 00:07:55.392854158 +0800
+@@ -0,0 +1,10 @@
++# -*- coding: utf-8 -*-
++from doctest import ELLIPSIS
++
++
++def setup_test(test):
++ for example in test.examples:
++ example.options.setdefault(ELLIPSIS, 1)
++
++setup_test.__test__ = False
++
diff --git a/dev-python/webtest/webtest-1.3.4.ebuild b/dev-python/webtest/webtest-1.3.4.ebuild
new file mode 100644
index 000000000000..212b616fa01b
--- /dev/null
+++ b/dev-python/webtest/webtest-1.3.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.3.4.ebuild,v 1.1 2012/05/20 01:19:38 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.1 *-jython *-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-python/webob-0.9.2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pyquery )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-index_fixt.patch"
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ sphinx-build docs html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ # Avoid future-import bug on py2.5.* - lint3 is py3 anyway
+ delete_lint3() {
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+ rm "${ED}$(python_get_sitedir)/webtest/lint3.py"
+ }
+ python_execute_function -q delete_lint3
+
+ if use doc; then
+ dohtml -r html/*
+ fi
+}