summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-12-09 15:50:38 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-12-09 15:50:38 +0000
commitbfba9f673ac3d5a0e12cb0c74274135e21c0d3b5 (patch)
treeed4428fda446dbed5df03a618e30010505bef156 /dev-python/visual
parentBump sys-cluster/openmpi-1.4 (diff)
downloadgentoo-2-bfba9f673ac3d5a0e12cb0c74274135e21c0d3b5.tar.gz
gentoo-2-bfba9f673ac3d5a0e12cb0c74274135e21c0d3b5.tar.bz2
gentoo-2-bfba9f673ac3d5a0e12cb0c74274135e21c0d3b5.zip
Now the correct boost version is always used (bug #271019, thanks to Sebastian Mingramm <s.mingramm@gmx.de>)
(Portage version: 2.2_rc56/cvs/Linux i686)
Diffstat (limited to 'dev-python/visual')
-rw-r--r--dev-python/visual/ChangeLog7
-rw-r--r--dev-python/visual/visual-5.12.ebuild17
-rw-r--r--dev-python/visual/visual-5.13.ebuild17
3 files changed, 34 insertions, 7 deletions
diff --git a/dev-python/visual/ChangeLog b/dev-python/visual/ChangeLog
index 82accfb83477..496f5928ea5f 100644
--- a/dev-python/visual/ChangeLog
+++ b/dev-python/visual/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/visual
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.33 2009/12/04 07:20:15 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.34 2009/12/09 15:50:38 grozin Exp $
+
+ 09 Dec 2009; Andrey Grozin <grozin@gentoo.org> visual-5.12.ebuild,
+ visual-5.13.ebuild:
+ Now the correct boost version is always used (bug #271019, thanks to
+ Sebastian Mingramm <s.mingramm@gmx.de>)
04 Dec 2009; Andrey Grozin <grozin@gentoo.org> -visual-5.03_rc1.ebuild:
Cleaning an old version
diff --git a/dev-python/visual/visual-5.12.ebuild b/dev-python/visual/visual-5.12.ebuild
index 693c19b6c939..871b24a0ac90 100644
--- a/dev-python/visual/visual-5.12.ebuild
+++ b/dev-python/visual/visual-5.12.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.12.ebuild,v 1.1 2009/09/19 13:35:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.12.ebuild,v 1.2 2009/12/09 15:50:38 grozin Exp $
EAPI=2
-inherit eutils python
+inherit eutils python flag-o-matic versionator
MY_P="${P}_release"
S="${WORKDIR}/${MY_P}"
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="visual"
-RDEPEND="=dev-libs/boost-1.35*
+RDEPEND=">=dev-libs/boost-1.41.0[python]
dev-cpp/libglademm
>=dev-cpp/gtkglextmm-1.2
dev-python/numpy"
@@ -26,6 +26,17 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.41.0")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ #We have to use a hack here because the build system doesn't provide a way to specify
+ #the include and lib directory for boost
+ append-cxxflags -I${BOOST_INC}
+ append-ldflags -L${BOOST_LIB}
+
econf \
--with-html-dir=/usr/share/doc/${PF}/html \
--with-example-dir=/usr/share/doc/${PF}/examples \
diff --git a/dev-python/visual/visual-5.13.ebuild b/dev-python/visual/visual-5.13.ebuild
index 139daec58bf6..ab7a73fc2241 100644
--- a/dev-python/visual/visual-5.13.ebuild
+++ b/dev-python/visual/visual-5.13.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.13.ebuild,v 1.1 2009/10/20 16:13:47 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.13.ebuild,v 1.2 2009/12/09 15:50:38 grozin Exp $
EAPI=2
-inherit eutils python
+inherit eutils python flag-o-matic versionator
MY_P="${P}_release"
S="${WORKDIR}/${MY_P}"
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="visual"
-RDEPEND="=dev-libs/boost-1.35*
+RDEPEND=">=dev-libs/boost-1.41.0[python]
dev-cpp/libglademm
>=dev-cpp/gtkglextmm-1.2
dev-python/numpy"
@@ -26,6 +26,17 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.41.0")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ #We have to use a hack here because the build system doesn't provide a way to specify
+ #the include and lib directory for boost
+ append-cxxflags -I${BOOST_INC}
+ append-ldflags -L${BOOST_LIB}
+
econf \
--with-html-dir=/usr/share/doc/${PF}/html \
--with-example-dir=/usr/share/doc/${PF}/examples \